highlighting broken in build 254

I thought I had problems with circular bin references, but i got those fixed in build 253, and this morning I re-upgraded to 254 only to find that its highlighting and reference seeking is definately broken. if you make a chain of class1.class2.class3.method() class 2 or 3 could be highlighted red with no reference, but if you get the things further down the line correct, they show their highlighting proper. Included is a screen capture to display this bug more clearly.

Recorded with techsmith camtasia... you need the Techsmith Screen capture codec to view it at http://www.techsmith.com/download/codecs.asp Its the best codec for capping programming screen videos.

All files in bin folder are project output references.



Attachment(s):
resharper254 reference screwup.avi
3 comments
Comment actions Permalink

I forgot to mention... this bug crops up at inconsistant times.... It seems like sometimes re-opening the file, or building the solution will fix it. Other times it seems to be directly caused by hitting f5 and starting to debug the project.

0
Comment actions Permalink

Thiss error is still in build 255.

Aren't more people with complex asp.net 2.0 solutions having this problem?

0
Comment actions Permalink

Build 256 breaks my cross assembly references alltogether and doesn't even get them in the using statements... so i can only assume that this bug is still around in 256.... Still stuck rolling with build 253 & 900 megs of memory consumed by devenv.exe

only 12 or so projects in the solution shouldn't break things as badly as this.

0

Please sign in to leave a comment.