Can not uncheck startup checkbox in Add-in Manager

Hi to All,

Problem .1:
If I uncheck the StartUp checkbox in Tools / Add in Manager for Resharper,
click OK, then reopen this dialog, the StartUp checkbox is checked again.

As a concusion I can not configure my VS to not load ReSharper at starting
up.

-


Problem 2:

Other Q: How can I preven auto loading Resharper if accdently pressing on of
assigned shotcut key when it is actually unloaded?

Currently I start VS, must wait for Resharper to load, go to Addin Man,
manually unload, wait to unload, and if I accidently press any shortcut,
then: "not again!"

Any ideas?

thx for help



4 comments
Comment actions Permalink

Hello john,

what version of VS you're using? If it is VS 2005, then there is a known
bug in it causing the 'Startup' checkbox to be not respected. You can still
manuall prevent ReSharper from loading on startup by setting '0' in the following
registry value: HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\
ReSharperAddIn2005\LoadBehavior

Concerning the second problem, it is the default behavior of VS to load the
add-in when the user invokes a command associated with that add-in. You can
change the keyboard mapping scheme to avoid invoking commands associated
with ReSharper, but this means that you will have to change it back when
you decide to load ReSharper.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi to All,

Problem .1:
If I uncheck the StartUp checkbox in Tools / Add in Manager for
Resharper,
click OK, then reopen this dialog, the StartUp checkbox is checked
again.
As a concusion I can not configure my VS to not load ReSharper at
starting up.

---------
Problem 2:
Other Q: How can I preven auto loading Resharper if accdently pressing
on of assigned shotcut key when it is actually unloaded?

Currently I start VS, must wait for Resharper to load, go to Addin
Man, manually unload, wait to unload, and if I accidently press any
shortcut, then: "not again!"

Any ideas?

thx for help



0
Comment actions Permalink

Hi Dmitry,

Thx for your detailed answer.
It works.

btw it was VS 2005.
-




"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> az alábbiakat írta a
következo hírüzenetben: c8a894d919fb648c869b15de41b25@news.intellij.net...

Hello john,

>

what version of VS you're using? If it is VS 2005, then there is a known
bug in it causing the 'Startup' checkbox to be not respected. You can
still
manuall prevent ReSharper from loading on startup by setting '0' in the
following registry value:
HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\
ReSharperAddIn2005\LoadBehavior

>

Concerning the second problem, it is the default behavior of VS to load
the add-in when the user invokes a command associated with that add-in.
You can
change the keyboard mapping scheme to avoid invoking commands associated
with ReSharper, but this means that you will have to change it back when
you decide to load ReSharper.

>
>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Hi to All,
>>
>> Problem .1:
>> If I uncheck the StartUp checkbox in Tools / Add in Manager for
>> Resharper,
>> click OK, then reopen this dialog, the StartUp checkbox is checked
>> again.
>> As a concusion I can not configure my VS to not load ReSharper at
>> starting up.
>>
>> -


>> Problem 2:
>> Other Q: How can I preven auto loading Resharper if accdently pressing
>> on of assigned shotcut key when it is actually unloaded?
>>
>> Currently I start VS, must wait for Resharper to load, go to Addin
>> Man, manually unload, wait to unload, and if I accidently press any
>> shortcut, then: "not again!"
>>
>> Any ideas?
>>
>> thx for help
>>
>



0
Comment actions Permalink

Hi,

I don’t know if it’s any help but I have ReSharper 2.5.326.1 and DevExpress Tools (DXCore) installed, the DevExpress tools respects the Startup option but ReSharper does not.

I’m unsure if any of the VS hot fixes we install as part of the ReSharper install were to fix this problem as I see the original report of this was back in June.

Just to confirm:
Enable DevExpress and ReSharper in Add-in manager
Tick Startup box for both.
OK to the form.
Open Add-in manager, untick DevExpress and ReSharper, and untick the Startup options.
OK to the form.
(At this point the menu for DevExpress is removed but not ReSharper)
Open Add-in manager, ReSharper has it’s Startup option reticked which it should not, however DevExpress add-in does not and is as expected.

When restating VS DexExpress is still not loaded as expected.

Given the edit and continue problems I am facing I would really like ReSharper to remember it’s (disabled) settings, as you say this is a VS bug then perhaps you could see how the DevExpress add-in has worked around it.

Thanks,


Steve.

0
Comment actions Permalink

Hello Stephen,

actually I cannot see how ReSharper (or any other add-in) could work around
this VS problem with not remembering the Startup checkbox, since
the very fact that the add-in gets the control means that it was activated
by VS, and its initialization has already happened (at least partially).
The problem with different add-ins behaving in different ways may be caused
by that this problem seems to only happen with add-ins installed for all
users,
not only for the current one. But you can easily work around this problem
by yourself by going to the registry and modifying the following registry
value:


HKLM\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn25|


This value should be reset to 0 in order for VS not to load the add-in on
startup.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Hi,

I don't know if it's any help but I have ReSharper 2.5.326.1 and
DevExpress Tools (DXCore) installed, the DevExpress tools respects the
Startup option but ReSharper does not.

I'm unsure if any of the VS hot fixes we install as part of the
ReSharper install were to fix this problem as I see the original
report of this was back in June.

Just to confirm:

Enable DevExpress and ReSharper in Add-in manager

Tick Startup box for both.

OK to the form.

Open Add-in manager, untick DevExpress and ReSharper, and untick the
Startup options.

OK to the form.

(At this point the menu for DevExpress is removed but not ReSharper)

Open Add-in manager, ReSharper has it's Startup option reticked which
it should not, however DevExpress add-in does not and is as expected.

When restating VS DexExpress is still not loaded as expected.

Given the edit and continue problems I am facing I would really like
ReSharper to remember it's (disabled) settings, as you say this is a
VS bug then perhaps you could see how the DevExpress add-in has worked
around it.

Thanks,

Steve.



0

Please sign in to leave a comment.