resharper 2.5 messes with visual studio 2005 buttons

This is resharper 2.5 with VS 2005.

After installing resharper, my shift-tab key no longer decreases indents. I haven't figure out how to tell VS that I want this to be the shift-tab key. Has resharper mapped it to something else? How can I fix this - I like shift-tab to unindendt.

Second problem - after installing resharper, when I open a file using Control-N ("Type Search"?), I find that Visual Studio does not focus on the file in the solution explorer. I expect it should. I believe it used to.

My intall order has been:
1) VS 2005 on machine already
2) install resharper
2b) (later notoiced I have no step into button)
3) reset VS environmental options (I missed the VS "step into" key, and reset the environmental options to get it back again.)
4) resharper shortcuts no longer working - uninstall resharper.
5) reinstall resharper.
6) now cannot shift-tab or find file on solution explorer using Ctrl-N or Shift-Ctrl-N. It finds the file fine, but the solution explorer stutters a bit but does not focus on the file.

Thanks!

JP

3 comments
Comment actions Permalink

Hello,

Please, try the "Reset Shortcuts" button on ReSharper\Options\General page.
That should restore CtrlN, CtrlShiftN and other shortcuts. If ShiftTab
is not restored, please, assign it manually through Tools/Customize... "Keyboard"
button. The command name is "Edit.DecreaseLineIndent". The scope is "Text
Editor". Remember to look through the actions that you will miss after assigning
this shortcut in the "Shortcut currently used by:" combo.

This is resharper 2.5 with VS 2005.

After installing resharper, my shift-tab key no longer decreases
indents. I haven't figure out how to tell VS that I want this to be
the shift-tab key. Has resharper mapped it to something else? How can
I fix this - I like shift-tab to unindendt.

Second problem - after installing resharper, when I open a file using
Control-N ("Type Search"?), I find that Visual Studio does not focus
on the file in the solution explorer. I expect it should. I believe it
used to.

My intall order has been:

1) VS 2005 on machine already

2) install resharper

2b) (later notoiced I have no step into button)

3) reset VS environmental options (I missed the VS "step into" key,
and reset the environmental options to get it back again.)

4) resharper shortcuts no longer working - uninstall resharper.

5) reinstall resharper.

6) now cannot shift-tab or find file on solution explorer using Ctrl-N
or Shift-Ctrl-N. It finds the file fine, but the solution explorer
stutters a bit but does not focus on the file.

Thanks!

JP

Best regards,
Andrey Simanovsky


0
Comment actions Permalink

Thanks for the response. That fixed the first issue, with the non-working buttons.

What about the problem of visual studio not setting focus on files?

Thanks,

Secret Squirrel

0
Comment actions Permalink

It seems that "Track Active item in Solution Explorer" checkbox in the Tools/Options/Projects
and Solutions tab is unchecked. Probably it got unchecked after Visual Studio
settings were reset.

Thanks for the response. That fixed the first issue, with the
non-working buttons.

What about the problem of visual studio not setting focus on files?

Thanks,

Secret Squirrel

Best regards,
Andrey Simanovsky


0

Please sign in to leave a comment.