3.0 C# Edition - Package Load Failure

I'm having problems with VS - I can't get R# to load properly. I've uninstalled and reinstalled, but still get the following message:

"Package Load Failure

Package 'Visual Studio Environment Menu Package' has failed to load properly ( GUID + {751F10EB-11D2-BFC2-00C04F990235}). Please ....... etc"

Any ideas how I can get around this? It started last week after I upgraded my MSSQL installation from Express to Developer. I've also lost other packages (Ghost Doc, etc.).

Thanks

Sean

7 comments
Comment actions Permalink

Hello sean,

doesn't re-installing ReSharper help to get rid of the problem?


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Environment Menu Package'



0
Comment actions Permalink

Trying to re-enable R# from Tools | Addins gives:

"
The Add-in 'Resharper 3.0' failed to load or caused an exception. Would you like to remove this Add-in? If you choose yes, the file it was loaded from, 'C:\program files\jetbrains\reshprper\v3.0\vs8.0\bin\resharper.8.0.addin', will be renamed.

Error message: No such interface supported
Error number: 80004002
"

Not sure if that helps!

0
Comment actions Permalink

Hi Dmitry

No - I've uninstalled/reinstalled and also repaired. Still get the same error.

Thanks

Sean

0
Comment actions Permalink

Hello sean,

if you experience other packages load failures, besides ReSharper's package,
I'm afraid the best you can do is to repair VS installation. Apparently it
got corrupt somehow.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Hi Dmitry

No - I've uninstalled/reinstalled and also repaired. Still get the
same error.

Thanks

Sean



0
Comment actions Permalink

Thanks Dmitry, I'll give that a try.

0
Comment actions Permalink

Dmitry, just to let you know that the VS repair fixed it and all is now working again.

Thanks

Sean

0
Comment actions Permalink

Hello sean,

ok, that's great to hear :)


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Dmitry, just to let you know that the VS repair fixed it and all is
now working again.

Thanks

Sean



0

Please sign in to leave a comment.