Missing XML doc comment intellisense

Using Resharper 3.0.2 (build 3.0.415.4), I seem to have lost suggestions or intellisense for XML doc comments. If I put the cursor above a method and type "///", the editor creates the summary and parameter docs, but I get no suggestions when I type "<" within those comments. Not even "<see".

Has anyone experienced anything like this and can anyone suggest a fix? Thanks.

9 comments
Comment actions Permalink

This part of the intellisense mostly works for me. When I type tag. I just noticed that intellisense within tags is also broken in that ReSharper does not always drill down into namespaces and classes properly. If I type ]]> wrote in message
news:7695708.1189012476380.JavaMail.itn@is.intellij.net...

Using Resharper 3.0.2 (build 3.0.415.4), I seem to have lost suggestions
or intellisense for XML doc comments. If I put the cursor above a method
and type "///", the editor creates the summary and parameter docs, but I
get no suggestions when I type "<" within those comments. Not even "<see".

>

Has anyone experienced anything like this and can anyone suggest a fix?
Thanks.



0
Comment actions Permalink

Let's start to break it down. Are the XML doc comments suggested by Resharper or Visual Studio if I have my other suggestions coming from Resharper?

0
Comment actions Permalink

When you press "<" and see the list of possible tags - this is VS native
functionality
When you press "." in cref attribute, the is ReSharper' feature

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"flipdoubt" <no_reply@jetbrains.com> wrote in message
news:25808998.1189078276363.JavaMail.itn@is.intellij.net...

Let's start to break it down. Are the XML doc comments suggested by
Resharper or Visual Studio if I have my other suggestions coming from
Resharper?



0
Comment actions Permalink

Hi, Eugene! Would you know how to explicitly turn off and then turn on that feature or, like Fonzie slapping the side of a jukebox, somehow wake it up via some kind of hack?

0
Comment actions Permalink

Which one do you mean? Ours or VS'?

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"flipdoubt" <no_reply@jetbrains.com> wrote in message
news:5951994.1189084528643.JavaMail.itn@is.intellij.net...

Hi, Eugene! Would you know how to explicitly turn off and then turn on
that feature or, like Fonzie slapping the side of a jukebox, somehow wake
it up via some kind of hack?



0
Comment actions Permalink

If VS.NET provides the hinting for doc comments, then I want to "wake up" the feature in VS.NET.

0
Comment actions Permalink

We do not override popup by pressing "<"

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"flipdoubt" <no_reply@jetbrains.com> wrote in message
news:20801708.1189092729675.JavaMail.itn@is.intellij.net...

If VS.NET provides the hinting for doc comments, then I want to "wake up"
the feature in VS.NET.



0
Comment actions Permalink

So you're saying you do not know which VS.NET setting to tickle to "wake up" suggestions in XML doc comments. Is that correct?

0
Comment actions Permalink

I restored the behavior I was looking for by changing settings on Resharper's Completion Behavior settings page. Originally, my settings in the first section only had two options checked: (1) "Letters and digits" and (2) "Dots and other member selectors". It was not until I checked "'new' and other object creation keywords" that doc comment completion was restored. Maybe "<" counts as an object creation keyword for doc comments.

Anyway, I found my own answer.

0

Please sign in to leave a comment.