Find Usages Preview Performance

The overall performance of my 3.0.2 build 517 is acceptable except when I try to use the preview pane in the Find Usages window. Showing each preview I select takes about 10 seconds, even if I have selected it before. Any help?

Note that I still need to install Visual Studio SP1.

Don

5 comments
Comment actions Permalink

Hello Don,

Did you try the pre-release 3.0.3 nightly builds (available at http://www.jetbrains.net/confluence/display/ReSharper/Nightly+Builds)
? Do they make any difference? We have tried to improve experience with open
preview pane.

The overall performance of my 3.0.2 build 517 is acceptable except
when I try to use the preview pane in the Find Usages window. Showing
each preview I select takes about 10 seconds, even if I have selected
it before. Any help?

Note that I still need to install Visual Studio SP1.

Don

Best regards,
Andrey Simanovsky


0
Comment actions Permalink

I tried build 543 and got better though still way to long performance. Selecting an instance of the found method then selecting a different instance in the left pane of the Find USages window took 6 seconds (down from 10) to bring up the next preview.

However the more annoying symptom that I forgot to mention in my first post is that after I have done this and I try to type in the text editor it is taking about 13 seconds per character to react.

If I keep the preview panel hiden from the time I start up visual studio I experience no slowdowns even if I use the rest of the Find Usages feature.

NOTE: I still need to install SP1 could this have any bering on the issue?

thanks,
Don

0
Comment actions Permalink

Hello Don,

Could you try the next nightly build when it comes out? The critical fix
was missing in the 3.* branch.

I tried build 543 and got better though still way to long performance.
Selecting an instance of the found method then selecting a different
instance in the left pane of the Find USages window took 6 seconds
(down from 10) to bring up the next preview.

However the more annoying symptom that I forgot to mention in my first
post is that after I have done this and I try to type in the text
editor it is taking about 13 seconds per character to react.

If I keep the preview panel hiden from the time I start up visual
studio I experience no slowdowns even if I use the rest of the Find
Usages feature.

NOTE: I still need to install SP1 could this have any bering on the
issue?

thanks,
Don

Best regards,
Andrey Simanovsky


0
Comment actions Permalink

I installed nightly build Build 548 and the preview pane performance is back to what is was in 2.5 and the associated slowness in the text editor is gone as well.

Thanks for the quick response Andrey!

Don

0
Comment actions Permalink

I installed nightly build Build 548 and the preview pane performance
is back to what is was in 2.5 and the associated slowness in the text
editor is gone as well.

Good news.


Thanks for the quick response Andrey!

You're welcome.:)


Don

Best regards,
Andrey Simanovsky


0

Please sign in to leave a comment.