Help Update

After installation every new version of R# 4.0 and starting Visual Studio
2008 the "Help Update in Progress" form comes up and destroys parts of the
help information (I've installed MSDN english and german version).

kind regards
Josef

6 comments
Comment actions Permalink

Hello,

After installation every new version of R# 4.0 and starting Visual
Studio 2008 the "Help Update in Progress" form comes up and destroys
parts of the help information (I've installed MSDN english and german
version).


That is strange, because we do not have any Help Integration for MSDN 9 yet.

Which exactly information is destroyed?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

I see a long 'merging help' phase during the installation of 4.0, followed by an enormously long wait (which, STUPIDLY (MS fault, not yours!) blocks the IDE) for index rebuilding the first time you use F1 after installing R#.

0
Comment actions Permalink

I've the same behavior as Will Dean described!
Afterwards if "Dynamic Help" is activatet the message "No links are
available for the current selection." is displayed in the "Dynamic Help"
toolbar window.
A restart of Visual Studio 2008 is necessary to correct the "Dynamic Help"
problem

Josef



"Hahnl Josef" <hahnl@aon.at> schrieb im Newsbeitrag
news:fpluqr$tnm$1@is.intellij.net...

After installation every new version of R# 4.0 and starting Visual Studio
2008 the "Help Update in Progress" form comes up and destroys parts of the
help information (I've installed MSDN english and german version).

>

kind regards
Josef


0
Comment actions Permalink

Hello,

I've the same behavior as Will Dean described!
Afterwards if "Dynamic Help" is activatet the message "No links are
available for the current selection." is displayed in the "Dynamic
Help" toolbar window.
A restart of Visual Studio 2008 is necessary to correct the "Dynamic
Help" problem


So, on the second run of Visual Studio the problem is gone? Is this true?

Do you have any Visual Studio or Document Explorer instances running during
the R# installation?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

YES, on the second run of Visual Studio the problem is gone!

NO, I've no Visual Studio or Document Explorer instances running during the
R# installation!

Yes the "problem" looks really strange, isn't it?

Josef


"Serge Baltic" <baltic@intellij.net> schrieb im Newsbeitrag
news:dc0986bfb80558ca453403d77f2e@news.intellij.net...

Hello,

>
>> I've the same behavior as Will Dean described!
>> Afterwards if "Dynamic Help" is activatet the message "No links are
>> available for the current selection." is displayed in the "Dynamic
>> Help" toolbar window.
>> A restart of Visual Studio 2008 is necessary to correct the "Dynamic
>> Help" problem
>

So, on the second run of Visual Studio the problem is gone? Is this true?

>

Do you have any Visual Studio or Document Explorer instances running
during the R# installation?

>


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”

>


0
Comment actions Permalink

The thing which seems really strange to me is that JetBrains think there's no help integration in 4.0 / VS9, yet there's quite clearly a phase in the setup process which is installing help.

I don't really know anything about VSIP - maybe lots of the setup is not written by JB.

The only problem I've had in terms of already-running stuff is when there were some zombie dexplore.exe processes lying around from a previous VS failure of some kind. This causes the R# help to stop and tell you that you must be running as admin (because it's had a permission-denied on overwriting some file to do with help which dexplore had locked). Given that it was already into the elevated section of the setup, being told to run as admin wasn't terribly helpful. Killing the dexplore processes allowed a retry, though.

But 4.0 on VS9.0 is DEFINITELY installing help here.

0

Please sign in to leave a comment.