Error in R# 3.1 for VS2008

Hi all

I'm getting an error when firing up VS2008 with R# 3.1 installed:

"The add-in 'Resharper 3.1' failed to load the supplementary package '0c6e6407-13fc-4878-869a-c8b4016c57fe'. It is recommended that you re-install the product 'ReSharper 3.1'."

I've uninstalled, installed and I've tried repairing the install as well, I've done this serveral times and I still get this error.

Any ideas?

Thanks
Kev

10 comments
Comment actions Permalink

Hello,

"The add-in 'Resharper 3.1' failed to load the supplementary package
'0c6e6407-13fc-4878-869a-c8b4016c57fe'. It is recommended that you
re-install the product 'ReSharper 3.1'."

I've uninstalled, installed and I've tried repairing the install as
well, I've done this serveral times and I still get this error.


What do the R# logs say (%TEMP%/JetLogs)?

Maybe there is any information regarding the abovementioned guid '0c6e6407-13fc-4878-869a-c8b4016c57fe'
in the Visual Studio logs (see “devenv.exe /?” for details on logging)?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

I encountered the same issue here. Please see the attached logs.



Attachment(s):
JetBrainsLog.2008-02-09T13-54-20.devenv#4648.log
deLog.log
0
Comment actions Permalink

Hello,

I encountered the same issue here. Please see the attached logs.


Strangely enough, I cannot see any errors in the logs. Was that a "Could
not load package" run?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

It was the same error that Kev/Mantorok reported:

-


ReSharper 3.1
-


The add-in 'ReSharper 3.1' failed to load the supplementary package '0c6e6407-13fc-4878-869a-c8b4016c57fe'.
It is recommended that you re-install the product 'ReSharper 3.1'.



Attachment(s):
R#.png
0
Comment actions Permalink

I managed to get ReSharper working by installing CodeRush. ;) (All of the developers at my company use CodeRush except for me, the lonely ReSharper standout. I much prefer R# features to that of CodeRush/Refactor.) I thought I would try using CodeRush again if R# was not going to work on this particular computer.

Anyway, R# loads now without an error EXCEPT if I start devenv with logging enabled which throws this error twice if I select "No" to disable loading the package in the future:

Package Load Failure
Package 'JetBrains.ReSharper.VS, Version=3.1.584.3, Culture=neutral, PublicKeyToken=null' has failed to load properly ( GUID = {0C6E6407-13FC-4878-869A-C8B4016C57FE} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading.

Simon



Attachment(s):
devenv.log
0
Comment actions Permalink

I've run into the same error. My resharper logs don't show anything, nor does devenv /log, which is attached.

My only other thing to note is that I didn't run into this orginally, but then uninstalled resharper, worked for a while, and then wanted to re-install, and it doesn't work. I'm also using the trial version.

My guid is also different, thought that probably doesn't matter.



Attachment(s):
vs.log
0
Comment actions Permalink

I've had the exact same error, I managed to resolve it by opening up the Visual Studio command prompt and entering:

devenv /ResetSkipPkgs

Then starting up VS2008 as normal seemed to get it working again. Hope this helps someone!

0
Comment actions Permalink

Pete

Thanks for the devenv switch - that has resolved it for me too.

Kev

0
Comment actions Permalink

Hello,

The investigation shows that the

devenv.exe /setup

stage of the installation sometimes would fail to make the necessary changes.
Presence of the R# menu indicates that it ran, but somehow did not succeed
in making ALL of the modifications to Visual Studio.

If you have the following situation:

1) The R# AddIn loads successfully, is present in Tools->AddIns.
2) The R# Package could not be loaded, and the error message is by R#.

Then it can be probably fixed by running "devenv.exe /setup" from an administrative
account.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Executive summary: run VS2008 devenv /resetskippkgs & devenv /setup also solves VS2005 issues.

Context:
- VS2005 installation with R# 3.1
- VS2008 installation without R#

VS2005 suddenly had same problem as described above: The add-in 'ReSharper 3.1' failed to load the supplementary package '0c6e6407-13fc-4878-869a-c8b4016c57fe'.

I also noticed that Help > About in VS2005 displayed this error, even after uninstall of R#. Note that VS2008 did not display this error.
-


Microsoft Visual Studio
-


Package Load Failure

Package 'Visual Studio Tools for Applications Project System Package' has failed to load properly ( GUID = {24D0CBA5-DFEB-4770-B6F9-C3D648A3C564} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading.
-


Yes No
-




I tried the following, without a positive result:
- uninstall R# 3.1 for VS2005
- install R# 3.1 for VS2005
- repair VS2005 installation - caused error Microsoft .NET Framework 2.0: Error code 1603 for this component means "Fatal error during installation. Probably because .NET 2.0 installer cannot be run once .NET 2.0 SP1 and/or .NET 3.5 are installed
- VS 2005 command prompt : devenv /setup
- VS 2005 command prompt : devenv /resetskippkgs
- repair .NET Framework 2.0 SP1
- repair .NET Framework 3.5

In a last act of despair, I was able to solve the VS2005 problem by running these commands on the VS2008 command prompt (!):
- devenv /setup
- devenv /resetskippkgs

HTH,

Bernard

0

Please sign in to leave a comment.