VS2005 Extremely unstable when R# 3.1 enabled

I've been using Resharper for a few years now and haven't seen this behavior until recently... Unfortunately I haven't been able to figure out how to resolve it. If I have R# enabled in add-in manager Visual Studio becomes extremely unstable. For example, I just open a class, type "private" and as soon as I hit the spacebar VS just shuts down. No error, no warning, no nothing. Just completely shuts down. If I check my Event Viewer I get this error:

.NET Runtime version 2.0.50727.1433 - Fatal Execution Engine Error (79FFEE24) (80131506)

So I go into add-in manager and turn off Resharper and everything works fine - no more crashes. This seems to only happen with a solution that has a class library and an asp.net website. I opened another solution which just has a website project and it worked fine. Then I tried to re-open the other solution and VS crashed with a data dump, which I've attached here. Hopefully that will help...?

For now I've disabled R# so I can get some work done, but I'm hoping to get this resolved soon - I hate working without R#!

Thanks for the help - eddie



Attachment(s):
4865_appcompat.zip
3 comments
Comment actions Permalink

eappell wrote:

I've been using Resharper for a few years now and haven't seen this behavior until recently... Unfortunately I haven't been able to figure out how to resolve it. If I have R# enabled in add-in manager Visual Studio becomes extremely unstable. For example, I just open a class, type "private" and as soon as I hit the spacebar VS just shuts down. No error, no warning, no nothing. Just completely shuts down. If I check my Event Viewer I get this error:

.NET Runtime version 2.0.50727.1433 - Fatal Execution Engine Error (79FFEE24) (80131506)

So I go into add-in manager and turn off Resharper and everything works fine - no more crashes. This seems to only happen with a solution that has a class library and an asp.net website. I opened another solution which just has a website project and it worked fine. Then I tried to re-open the other solution and VS crashed with a data dump, which I've attached here. Hopefully that will help...?

For now I've disabled R# so I can get some work done, but I'm hoping to get this resolved soon - I hate working without R#!

Thanks for the help - eddie

Hi,

Just FYI... I had the same behavior with asp.net and vs2005 and
Resharper 3.x. Crash after Crash. I gave up on Resharper after MUCH
productivity loss.

But. We recently purchased VS2008 and I reluctantly installed
Resharper 3.1 and it's been doing fine with that same asp.net project
for a couple weeks now! ]]>

Good Luck,
Tony

0
Comment actions Permalink

Thanks Tony. Unfortunately we're not planning an upgrade to VS 2008 yet. Could be a while before that happens, so I need to find an alternate fix. I think it's related to the ASP.NET 3.5 Extensions CTP I have installed. I'm going to uninstall a bunch of the Microsoft extensions I have (LINQ Preview, etc) and hopefully that will get this working again...

0
Comment actions Permalink

Hi,

I don't know how to fix it fro Resharper (I don't have the source code) , but I know what causes it. I've encountered it myself. It has to do with managed code freeing resources. See http://www.codeproject.com/KB/security/CryptoInteropKeys.aspx

Jeff

0

Please sign in to leave a comment.