ReSharper overwrites Service Pack 1 functionality

Visual Studio 2008 Service Pack 1 provided some great features, which I lost when installed the latest version of ReSharper, so I decided to uninstall it. But those features were still gone....

I uninstalled Visual Studio 2008, installed it again and installed the Service Pack 1, but STILL the features is gone....

How can I get them back?

5 comments

What exactly the features you are missing?

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

My english sucks, but I will try to explain..

The feature I miss the most is that when I installed Service Pack 1 I got errors while coding, without having to build/compile (like it has been in VB for years, but finally this was also available in C#)

I hoped that I could just remove the Ad-in for the projects where th ReSharper does not work (i.e. my WebService projects), and get the old VS2008 "settings" back, but it didn't..so now the situation is:
If I use resharper: I get errormessages, but no intellisense on webservices.
If I disable the add-in: I get intellisense, but no errormessages (before I compile)

And when I tried to unistall everything (both VS2008 and resharper) and reinstalled, it was the same as just disable the add-in

I need both, like I did when I installed Service Pack 1

0

T E schrieb:

The feature I miss the most is that when I installed Service Pack 1 I got errors while coding, without having to build/compile (like it has been in VB for years, but finally this was also available in C#)


Tools->Options->Text-Editor->C#->Advanced->Editor Help

Underline errors in editor
Show live semantics errors


Regards

Albert

0

Hello,

If I use resharper: I get errormessages, but no intellisense on
webservices.


Why not use R# error highlightings but Visual Studio IntelliSense, then?
This way you'll have them both.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Thanks!

Both solutions worked like I wanted!

0

Please sign in to leave a comment.