Naming convention = more flexibility please

I have a wierd rule - my local variables start with the tmp prefix (i.e. tmpPoint, tmpList etc.)
On top of that, I allow the loop variables to be i, j, k.
Is there a possibility to be that flexible? Of course, I do not insist on checking if the variable is a loop one, but it would be nice if
there was a way to specify a rule as "tmp + Name" or "i" or "j" or "k"?

My convention is:
by value params = in+Name i.e. inArgs, inPoint etc.
params with out or ref keywords = out+Name (i.e. outValue) or ref+Value (i.e. refValue)

So the question is: would it be possible to make a change to validate the parameter kind (regular, out, or ref) and apply the rule accordingly?

Please sign in to leave a comment.