Help with resharper 4.5

Hi

I recently upgraded from resharper 4.1 to 4.5 for VS2008 and since then my life has been miserable.

Normal developement itself is fine except starting up my solution (I only have 7 assemblies in my solution) is now taking in the order of minutes.

When I try to run unit tests, it seems quire responsive but when in debug mode (either through webdev or unit tests) the experience is quite bad.
It takes around a couple of minutes (much longer than just plain VS 2008) during which VS 2008 becomes totally white/frozen/unresponsive.

I guess it has to do with loading the debug symbols but it is unbearable when you press Alt-R-U-D and then have to wait a few minutes for the program context to enter the unit test.
Starting webdev when using Resharper in debug mode is worse.

I searched the forums and I couldn't find anything about
a) anybody else having a similar issue
b) a download link for going back to resharper 4.1

My environment is VS 2008, Resharper 4.5 (build 4.5.1231), Sql server 2005, XP professional.  I am running it on a laptop with 3 GB Ram which is not great but not bad
I also don't have any other plug-ins (like snippetdesigner) which might be causing the issue (yes, I searched the forums for that too)

If you have any suggestions, I would appreciate it

Thanks
Rao Venugopal

2 comments

Do you have a website project?

At any rate, we had one developer who claimed a 5 minutes start up time for
a solution with a large website project... significantly longer than under
4.1. After a few emails back and forth, I foudn that this fixed his problem
completely:

Go to the ReSharper menu -> Options... -> General -> and Scroll down and
select "Store Caches in System TEMP Folder" radio button under the "System"
heading.

You may then wish to delete by hand any ReSharper caches, files, and folders
from your project folders:

• Close all instances of VS
• In Windows Explorer, select the root directory/folder for all your
projects/source code
• Enter "ReSharper" in the Search box in the upper right (assuming Vista),
without the quotes. For XP, you'll need to do a search of all subfolders.
• Wait for it to find all references (folders and files)
• Select everything, and delete
• Close the Explorer window

That will free up your disk space and clean up your project and solution
folders, and will also speed up Website project load times dramatically.

I have no idea why Resharper doesn't just default to using the TEMP folder
for its caches.


"Rao Venugopal" <no_reply@jetbrains.com> wrote in message
news:29700844.77311239650502559.JavaMail.clearspace@app8.labs.intellij.net...

Hi

>

I recently upgraded from resharper 4.1 to 4.5 for VS2008 and since then my
life has been miserable.

>

Normal developement itself is fine except starting up my solution (I only
have 7 assemblies in my solution) is now taking in the order of minutes.

>

When I try to run unit tests, it seems quire responsive but when in debug
mode (either through webdev or unit tests) the experience is quite bad.
It takes around a couple of minutes (much longer than just plain VS 2008)
during which VS 2008 becomes totally white/frozen/unresponsive.

>

I guess it has to do with loading the debug symbols but it is unbearable
when you press Alt-R-U-D and then have to wait a few minutes for the
program context to enter the unit test.
Starting webdev when using Resharper in debug mode is worse.

>

I searched the forums and I couldn't find anything about
a) anybody else having a similar issue
b) a download link for going back to resharper 4.1

>

My environment is VS 2008, Resharper 4.5 (build 4.5.1231), Sql server
2005, XP professional. I am running it on a laptop with 3 GB Ram which is
not great but not bad
I also don't have any other plug-ins (like snippetdesigner) which might be
causing the issue (yes, I searched the forums for that too)

>

If you have any suggestions, I would appreciate it

>

Thanks
Rao Venugopal

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5235750#5235750


0

On 21.04.2009 23:25, Paul Bradshaw wrote:

Go to the ReSharper menu -> Options... -> General -> and Scroll down and
select "Store Caches in System TEMP Folder" radio button under the
"System" heading.



That will free up your disk space and clean up your project and solution
folders, and will also speed up Website project load times dramatically.

I have no idea why Resharper doesn't just default to using the TEMP
folder for its caches.


Well, I did consider using the TEMP folder as a general path for caches
as well, but since a lot of programs tend to dump some stuff in there,
my shutdown-script is cleaning up the TEMP folder on every shutdown. So
this would actually cause to recreate all the caches after every boot.

You might want to consider this is as well ... and that migth be a
reason why it's not R# default behavior.

0

Please sign in to leave a comment.