Setting R#'s keyboard shortcuts in VS.NET 2008

Hello, I have problem setting R#'s keyboard shortcuts in VS.NET 2008. Even when I use menu ReSharper-->Options-->Environment-->General  , set "Visual Studio" and press "Apply", most of the shortcuts are not set. Some of them yes (Ctrl+D), but most no (Ctrl+N, Ctrl+Shift+F7, Ctrl+Alt+Space etc. ). I had to set them manualy accordingly to settings made on my previous notebook, but it's quite annoying. It this a known problem? Thanks.

3 comments

Hello,

set "Visual Studio" and press "Apply", most of the shortcuts are not
set. Some of them yes (CtrlD), but most no (CtrlN, CtrlShiftF7,
CtrlAltSpace etc. ).


The CtrlN and CtrlShift+F7 shortcuts are originating in IntelliJ IDEA,
so to set them you have to use another radio button choice. The Visual Studio
scheme strives to keep as many native VS shortcuts as possible, so it leaves
CtrlN for File | New, and Goto Type is assigned to CtrlT (yes it overrides
the Visual Studio swap characters action, would you ever use that anyway?..).
ReSharper menu items in the main menu have their shortcuts displayed next
to them.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Hello, thank you for replay. I used VS.NET 2005 with R# before, used same shortcut settings as I described and everything worked, so I expected the same behavior being applied in VS.NET 2008. It might be that first version of R# I installed on my previous notebook was 2.x., but I'm almost sure that I applied there Visual Studio shortcuts many times even with newer versions of R#...

0

Hello,

Applying VS shortcuts will not wipe out non-conflicting shortcuts (like Ctrl+N
that's not used by the VS-friendly scheme). If you ever had R# 2 or below,
or a newer version with IDEA-family shortcuts, they'll remain assigned until
you do Tools | Import and Export Settings | Reset All Settings.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.