Resharper menu missing

When I start VS2008 I see the normal indications that ReSharper is loading and parsing assemblies. The gutter shows symbols for code analysis and light bulbs show up on selected lines. However, I no longer have a ReSharper menu in the menu bar and the context menu no longer shows any of the ReSharper items. My shortcuts all seem to be non-functioning as well.  I tried booting from the command line with /ResetSettings, and I even tried reinstalling 4.5.1274.1 but no joy.

Any idea how to get the menu, context menu, and keyboard shortcuts back?

6 comments

The key to solving this was to run Visual Studio from the command line with the /ResetSkipPkgs flag. This caused lots of errors but I didn't accept any of the dialog prompts that offered to disable R# for me.  The errors also gave me the clues I needed to identify a mis-behaving plug-in that was disabled but not completely uninstalled. I then uninstalled that plug-in and restarted Visual Studio and R# was back to normal.  

0

Dear Tod,

I had the same problem and your thread gave me the hint needed, so thank you a lot!
I had to use the option /ResetSettings though to resolve the problem here. /ResetSkipPkgs did not help.

Regards,
Joe

0

I just re-installed Resharper 2017 and now I do not see the ReSharper menu.  I tried the command line options suggested above and that did not work.  I tried un-installing and re-installing, rebooting, and everything else I could possibly think of.  The installer indicates that it is installed, but its not showing up.

Help!

0

Hello Paul!

 

Please try suggestions described in the following help article - https://resharper-support.jetbrains.com/hc/en-us/articles/20724184

Please let us know if it helps.

Thank you.

0

Please sign in to leave a comment.