Using [space] to close intellisense but not select an item

In visual studio's intellisense its possible to tell intellisense to not use space as a character to complete what it thought you were typing, in other words it will just dismiss the popup leaving your typed text as is.

Is this possible to do with the Resharper intellisense? I looked through all of the settings but didn't see an obvious one that did this.

Thanks,

James

1 comment

[v4.5.1288.2]
I too have this problem, or similar at least. It completes when I am writing a dot (".").
It happens to me frequently when I want to type "System.Exception", Intellisense then displays SystemException" when (for some reason it doesn't show the System namespace until I hit escape and then do it all over again).
I continue to type since I don't want SystemException and when I hit "." it inserts SystemException, even though that is not what I wanted. I want to complete the thing I'm writing.

I would like to have the option to insert suggested intellisense item with e.g. only [Tab].

0

Please sign in to leave a comment.