Resharper Slow in .aspx

I have Resharper 4.5.1231

Regardless of what build this is, I'm pretty sure I'll get this problem in any of the most recent builds.  It's every time I'm working in an .aspx resharper totally jacks me.  When I type something, anything, resharper causes my cursor to show that it's processing something.  So I consequently end up spending half mytime waiting ont he cursor for me to be able to type again because resharper tries to do something...not even intellisense related every damn time.

What can I do to rid this problem other than uninstalling Resharper!?

12 comments

Hi,

I see this too even with the latest build in small web solutions. Something
is broken in Resharper.

John

"Dave Schinkel" <no_reply@jetbrains.com> wrote in message
news:7461375.68431254850692450.JavaMail.clearspace@app8.labs.intellij.net...
>I have Resharper 4.5.1231
>

Regardless of what build this is, I'm pretty sure I'll get this problem in
any of the most recent builds. It's every time I'm working in an .aspx
resharper totally jacks me. When I type something, anything, resharper
causes my cursor to show that it's processing something. So I consequently
end up spending half mytime waiting ont he cursor for me to be able to
type again because resharper tries to do something...not even intellisense
related every damn time.

>

What can I do to rid this problem other than uninstalling Resharper!?

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5246505#5246505


0

Hello
     Do you have Ankh SVN installed? Do I understand correctly that disabling ReSharper under Tools > Add-In Manager brings performance back to the normal level? As to the snapshot (the main thread in particular), it shows that 30% of the time is spent inside Ankh SVN and another 25% is spent inside Visual Studio web forms code generator and only 15% - inside ReSharper.

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"
0

We don't use Ankh SVN (we use TFS Team System), and I'm hearing the same
thing from developers here... that using website projects and typing in aspk
files is so slow that even though they love the features of reshaper, they
have to uninstall it to get any work done.  For instance it takes well over
5 full minutes to load a website project with Resharper, but only seconds to
load it without.

This has been an issue for a long time now.  It's gotten fractionally better
here and there, only to get worse again, as new versions are released.

This really, really needs to be fixed.

"Andrey Serebryansky" <no_reply@jetbrains.com> wrote in message
news:19307166.72761254994723342.JavaMail.clearspace@app8.labs.intellij.net...

Hello
Do you have Ankh SVN installed? Do I understand correctly that disabling
ReSharper under Tools > Add-In Manager brings performance back to the
normal level? As to the snapshot (the main thread in particular), it shows
that 30% of the time is spent inside Ankh SVN and another 25% is spent
inside Visual Studio web forms code generator and only 15% - inside
ReSharper.

>

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5246645#5246645


0

Hello Paul
     Could you please gather a performance snapshot of the problem following the instructions at http://www.jetbrains.net/confluence/display/ReSharper/ReSharper+Performance+Profiling+Instructions and send it to andrew dot serebryansky at jetbrains dot com? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

Greetings Andrey,

I have been plagued with this issue on Windows XP SP-3 and Visual Studio Team System 2008 for some time now. The ONLY way I can even use ReSharper is to open VS 2008, click the ReSharper menu, then head into Options and clear the caches (in the General section). I can then open any solution and get to work - otherwise, no dice.

This is a problem with caching that in my simple mind could be dealt with by a build that just clears the caches when a solution is opened. It would get us through until you determine the root cause.

I, like so many others are growing tired of you asking us to attach to the hung process or do some tracing voodoo. I do not have time for this nonsense and it's not what I paid for when I bought my license of ReSharper. Please fix this problem.

Thank you,
Jeff

0

Hello Jeff
     Could you please clarify what kind of behavior do you experience if you don't clear caches before opening your solution? Does Visual Studio freeze or some actions become slower? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"
0

I have the same issue inside apsx pages. Even hitting the space bar causes R# to go into IAM-Working mode. I have to hit ctrl-8 to disable it.

I will try dotTrace.

0

Visual Studio 2008 TFS will lockup permanently. The only way to regain your sanity is to kill it with Task Manager.

0

I am seeing the same slow performance when editing .aspx files.  This seems to mainly affect Windows XP, as I've been working in Windows 7 lately and haven't seen the problem.

0

Mainly XP? Ok, I run XP (and vs2008).

Because unfortunately, I must again report that now, when I was editing a rather large ASPX file with 510 lines, total of 99 ASP controls (including Labels, UpdatePanel, ListItem, TextBox, etc), total of 42 DataBinder.Eval, with several complex calls to to code behind such as     <asp:CheckBox  runat="server" ID="chk_IsStarted"
                                        Checked='<%# Bind("is_started")%>'
                                        ToolTip="[text]"
                                        Text="[text]" CssClass="block checkboxWithText hideiftaskisfinished"  
                                        Enabled='<%# DisplayIsStarted(DataBinder.Eval(Container.DataItem, "task_id").ToString()) %>'
                                />                                        
                                <asp:CheckBox  runat="server" ID="Chk_Remind" Text="[text]"
                                    CssClass="block checkboxWithText hideiftaskisfinished"
                                    ToolTip="[text]"
                                    Checked='<%# GetChecked(DataBinder.Eval(Container.DataItem, "todo_id"))  %>'
                                />
                                <div>
                                    <asp:Image ID="FinishedImage" runat="server"
                                        Visible='<%# ShowIfNotNull( DataBinder.Eval(Container.DataItem, "finished_date"))  %>'
                                        ImageUrl="resources/ok_small.png" Width="12" >
                                    </asp:Image>    
                                    <%#  DataBinder.Eval(Container.DataItem, "finished_sign") %>    
                                    <%#  PrintIfExist(DataBinder.Eval(Container.DataItem, "finished_date"), " <br /> ") %>                                    
                                    <%#  DateTimeNoSec(DataBinder.Eval(Container.DataItem, "finished_date")) %>                
                                </div>

I find it very difficult to edit any sort of HTML because of studdering effect. If I type fast, the letters of a word don't appear until I completed typing the word. For a touch typist, this is very annoying.

This is despite having code analysis turned off. I am running latest EAP nightly build, but it has been the same in earlier builds too, and in 4.5. I have to resort to a simple text editor for any small changes to the HTML code, such as changing some text or CssClass .

I do appreciate the support that ReSharper 5 gives for ASP.NET files, such as how it creates the code-behind events with a click and verifies that the SelectMethod of ObjectDataSource is correct and has the correct parameters. But sometimes it is just important to type some HTML code fast, and that is very difficult.

0

Hello Fredrik
     Have you tried turning off the code analysis for the current file (Ctrl+8 in ReSharper 4.5 or Ctrl+Shift+Alt+8 in ReSharper 5.0)? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

Thanks for the reply.
Yes, code analysis is turned off.

0

Please sign in to leave a comment.