Transfer ALL R# 4.5 settings from VS 2008 to VS2005 and to VS2010

It just took me 2 hours to configure Resharper 4.5 with StyleCop for Resharper in VS 2008. Now I hope I don't have to go through all this for VS 2005 and VS2010 (once it and R# 5 is released) again. Is there a way I can transfer my settings? The best thing I can figure out so far is to to a diff between the files in %userprofile%\Application Data\JetBrains\ReSharper\v4.5\VS9.0 and the target directory but is it really guaranteed that the settings for R#4.5 are 100% compatible between VS2005 and VS2008? Not to mention R#5 and VS2010?
Will R# 5.0 have a migration wizard or something during installation?

3 comments
Comment actions Permalink

Hello,

The settings are stored in the UserSettings.xml file under the roaming application
data folder. You could copy the fully configured file to other VS versions,
or delete settings files for other versions to make R# look for existing
settings files in other VS versions on the first run.

After that, settings files for different VS versions will live on their own,
unfortunately (they won't stay in sync). You could share the single settings
file using NTFS junctions of course, but in this case it's not guaranteed
to run correctly if you run more than one VS version at the same time.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Thanks. So the resharper 4.5 settings file for VS 2008 is 100% compatible to the VS 2005 one? Aren't there some settings that only make sense in VS2008 and do not in 2005 (like C# 3.0 things like var and lamdas)?

0
Comment actions Permalink

Hello,

These settings are not likely to ruin anything.

Also I wouldn't be surprised if you could override Language Level on a project
in VS 2005 to make ReSharper treat it as C# 3. I assume it should be possible
(same way as you can restrict R# in VS 2008 to C#2 or C#4 features), but
I've never checked.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.