How do you stop indenting of summary tag contents?

Hi there,

I keep encountering this frustrating behavior where i will run code clean-up on a class and all my summaries get indented by two spaces. The REALLY frustrating part is that is doesn't happen all the time. Sometimes it will indent, sometimes it won't.

E.g.

/// <summary>
/// This code does something.
/// </summary>

becomes:

/// <summary>
///   This code does something.
/// </summary>



We've been using resharper for a long time and have hundreds of classes formatted without the indenting, and i have no idea how to stop it doing it.

Any suggestions?? Is there a setting for this??
1 comment
Comment actions Permalink

Hello Andrej,

Please make sure you're using a Code Cleanup profile which has 'Reformat
embedded XML doc comments' option turned off. Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi there,

I keep encountering this frustrating behavior where i will run code
clean-up on a class and all my summaries get indented by two spaces.
The REALLY frustrating part is that is doesn't happen all the time.
Sometimes it will indent, sometimes it won't.

E.g.

/// <summary>
/// This code does something.
/// </summary>
becomes:

/// <summary>
///   This code does something.
/// </summary>
We've been using resharper for a long time and have hundreds of
classes formatted without the indenting, and i have no idea how to
stop it doing it.

Any suggestions?? Is there a setting for this??

---
Original message URL:
http://devnet.jetbrains.net/message/5267690#5267690



0

Please sign in to leave a comment.