5.1.1755 - All kinds of features not working

VS 2010
I noticed this in earlier versions as well, 1753 and 54.

No shift/ctrl/F7 usage highlighting

No red squiggly pre-build error warning lines on typos

When I reference a known non-existing private method, the method does not turn red:
string methodName = DoThis("");  
DoThis should be red, reminding me that I need to create it.
Same for this kind of new non-existing method creation:
string whatever = instance.NonExistingMethod(); // NonExistingMethod should be red because it doesn't exist yet.

No Ctrl/click navigation (same as VS "Go to Implementation")
BTW, this feature, when it does work, works poorly in 5.n versions. I find myself having to click 2 or more times to get it to work, which a painful degradation of the feature. It doesn't seem to work on the first click. But now, it's not working at all.

These are many of my "use a million times a day" features. It's almost like not having R# at all.

Using R# keyboard shortcuts

I'll add to the thread if I find more.

4 comments
Comment actions Permalink

Hello,

Is ReSharper enabled under Tools | Options | ReSharper | General? Do ReSharper
| Navigate | Go To Type/File/Symbol work correctly? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

VS 2010
I noticed this in earlier versions as well, 1753 and 54.
No shift/ctrl/F7 usage highlighting

No red squiggly pre-build error warning lines on typos

When I reference a known non-existing private method, the method does
not turn red:

string methodName = DoThis("");

DoThis should be red, reminding me that I need to create it.

Same for this kind of new non-existing method creation:

string whatever = instance.NonExistingMethod(); // NonExistingMethod
should be red because it doesn't exist yet.

No Ctrl/click navigation (same as VS "Go to Implementation")

BTW, this feature, when it does work, works poorly in 5.n versions. I
find myself having to click 2 or more times to get it to work, which a
painful degradation of the feature. It doesn't seem to work on the
first click. But now, it's not working at all.

These are many of my "use a million times a day" features. It's almost
like not having R# at all.

Using R# keyboard shortcuts

I'll add to the thread if I find more.

---
Original message URL:
http://devnet.jetbrains.net/message/5275135#5275135



0
Comment actions Permalink

R# has always been on. The go to type is one of the features that has worked and still is. I'm still seeing all of the other features mentioned not working.

0
Comment actions Permalink

Hello,

Please run Visual Studio (devenv.exe) with /ReSharper.LogFile "C:\log.txt"
/ReSharper.LogLevel Verbose command line parameters, invoke the features
that do not work and attach the resulting log.txt file here. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

R

  1. has always been on. The go to type is one of the features that has

worked and still is. I'm still seeing all of the other features
mentioned not working.

---
Original message URL:
http://devnet.jetbrains.net/message/5275241#5275241



0
Comment actions Permalink

So far, 1756 seems to have cleared that up.

0

Please sign in to leave a comment.