5.1.1753.4 Features Not Working In VS2010

I'm having similar issues as the author of this posting: http://devnet.jetbrains.net/thread/291369?tstart=0  Specifically:

  • I'm not seeing red squiggly pre-build error warning lines under typos.

  • My Marker Bar isn't visible.

  • Shift/Ctrl/F7 usuage highlighting isn't working.

  • Ctrl-Click navigation isn't working.

  • Actually, no R# keyboard shortcuts are working.


Yet, R# is running, it alerts me to errors in the lower right corner of the VS2010 window ("1 file with errors"), and otherwise seems to be active.


For the record:

  • I've checked, and R# is indeed enabled (Tools -> Options -> ReSharper -> General).  The goto type/file/symbol commands work.

  • I don't have any 3rd party extensions or add-ons installed.  (See attached .txt file for a list of everything in my VS2010 installation, including version numbers.)

  • I've tried installing builds 1754, 1755, and 1756, but they have the same issues.

  • I've tried completely uninstalling R#, rebooting, and reinstalling.

  • Interestingly, all builds work fine in my VS2008 install.



I also tried to generate a log file for you using the /ReSharper.LogFile "C:\log.txt" /ReSharper.LogLevel Verbose command line options on devenv.exe, but even though R# loads, it doesn't generate a log file.


Any thoughts on how to get R# working again?



Attachment(s):
vs2010Info.txt.zip
2 comments
Comment actions Permalink

Hi,

Could you please try to delete following folders
%APPDATA%\Local\Microsoft\VisualStudio\10.0\ComponentModelCache
and %APPDATA%\Roaming\Microsoft\VisualStudio\10.0\ComponentModelCache.
Also you could try to run VS through command line with the following key
/resetskippkgs. Let me know if it helps.

--
Kirill Falk
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

On 10/23/2010 2:11 AM, Jon Humphreys wrote:

I'm having similar issues as the author of this posting: /thread/291369?tstart=0  Specifically:

>

  • I'm not seeing red squiggly pre-build error warning lines under typos.

>

  • My Marker Bar isn't visible.

>

  • Shift/Ctrl/F7 usuage highlighting isn't working.

>

  • Ctrl-Click navigation isn't working.

>

  • Actually, no R# keyboard shortcuts are working.

>

Yet, R# is running, it alerts me to errors in the lower right corner of the VS2010 window ("1 file with errors"), and otherwise seems to be active.

>
>

For the record:

>

  • I've checked, and R# is indeed enabled (Tools ->  Options ->  ReSharper ->  General).  The goto type/file/symbol commands work.

>

  • I don't have any 3rd party extensions or add-ons installed.  (See attached .txt file for a list of everything in my VS2010 installation, including version numbers.)

>
>

  • I've tried installing builds 1754, 1755, and 1756, but they have the same issues.

>

  • I've tried completely uninstalling R#, rebooting, and reinstalling.

>
>

  • Interestingly, all builds work fine in my VS2008 install.

>
>

I also tried to generate a log file for you using the /ReSharper.LogFile "C:\log.txt" /ReSharper.LogLevel Verbose command line options on devenv.exe, but even though R# loads, it doesn't generate a log file.

>
>

Any thoughts on how to get R# working again?

>

---
Original message URL: http://devnet.jetbrains.net/message/5275701#5275701



--

0
Comment actions Permalink

Hi Kirill,

Sorry for the delay in getting back to you.  I just got back into the office.

As for your three suggestions:

1) I deleted the %APPDATA%\Local\Microsoft\VisualStudio\10.0\ComponentModelCache folder.

2) On my system, there was no ComponentModelCache folder in the %APPDATA%\Roaming\Microsoft\VisualStudio\10.0\ folder.  That location exists and contains other folders (1033, Aliases, AutoRecoverDat, etc) as well as some files (Current.vsk, Debug.winprf_backup, etc), but there's no ComponentModelCache folder.

3) After doing #1, I ran Visual Studio 2010 from an administrator-privileged command prompt with the /resetskippkgs flag.  Specifically: Start Menu -> Search for "cmd" -> right-click on cmd.exe and select "Run as administrator" -> from the command prompt, navigate to the directory containing devenv.exe (Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE) -> execute the command line command "devenv.exe /resetskippkgs"

Resharper still behaves as before.  No change.

What would you recommend my next steps be?  And thanks very much for your help!

Jon

0

Please sign in to leave a comment.