Intellisense not working for User Control

Hi,

I have vs2008 with resharper 5.1. It's been like this since I tried the trial version.

My user controls don't get intellisense. In fact, their properties and methods are shown as red in the CS file. Is it because I have registered the User Controls in web.config? How can I make it work please?

Thanks,
Hao

3 comments
Comment actions Permalink

Hello Hao,

What's the exact version of ReSharper you're currently using? Could you please
attach a small sample solution demonstrating this behavior? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I have vs2008 with resharper 5.1. It's been like this since I tried
the trial version.

My user controls don't get intellisense. In fact, their properties and
methods are shown as red in the CS file. Is it because I have
registered the User Controls in web.config? How can I make it work
please?

Thanks,
Hao
---
Original message URL:
http://devnet.jetbrains.net/message/5276854#5276854



0
Comment actions Permalink

Hi Andrey,

Thanks for helping. I created a sample web solution that demonstrates the Intellisense problem I mentioned.

The  problem occurs in Default.aspx.cs file. The .Message property is shown in red, with an error tick appears on the right side of the scroll bar saying "can not resolve symbol Message".  But if I compile and run the website, it goes fine.

Here is the version of the Resharper I am using:

JetBrains ReSharper 5.1 C# Edition
Build 5.1.1753.4 on 2010-10-15T15:51:30

Licensed to: Hao Deng
Plugins: none.
Visual Studio 9.0.30729.4462.

Copyright © 2003–2010 JetBrains s.r.o.. All rights reserved.


Thank



Attachment(s):
WebSite1.zip
0
Comment actions Permalink

Hello Hao,

There's a corresponding bug-report in our tracker: http://youtrack.jetbrains.net/issue/RSRP-73036
and you're welcome to monitor its status. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Andrey,

Thanks for helping. I created a sample web solution that demonstrates
the Intellisense problem I mentioned.

The  problem occurs in Default.aspx.cs file. The .Message property is
shown in red, with an error tick appears on the right side of the
scroll bar saying "can not resolve symbol Message".  But if I compile
and run the website, it goes fine.

Here is the version of the Resharper I am using:

+JetBrains ReSharper 5.1 C# Edition
Build 5.1.1753.4 on 2010-10-15T15:51:30
Licensed to: Hao Deng
Plugins: none.
Visual Studio 9.0.30729.4462.
Copyright © 2003-2010 JetBrains s.r.o.. All rights reserved.+

Thank

---
Original message URL:
http://devnet.jetbrains.net/message/5277077#5277077



0

Please sign in to leave a comment.