New (and incorrect) errors flagged in 5.1.2

(posted originally in eap forum by mistake)

Since installing 5.1.2, I've noticed several errors flagged by ReSharper of
the following type:

"Argument type A.B.C.D ' is not
assignable to parameter type 'A.B.C.D "

The project builds fine, and this code wasn't flagged prior to installing
5.1.2.  There is no "Specific Version=true" flag anywhere.  Obviously the
types are compatible, so this message seems to be in error.

Do you know what could be causing this, how to fix it, and if this is a new
bug in ReSharper, or whether something else is going wrong?  Is there
something I can look at that would give you more information, or help me
find and fix the issue of why ReSharper thinks a given type isn't assignable
to itself?

Thanks!

2 comments

Hello Paul,

Have you tried clearing ReSharper caches? Close all instances of Visual Studio
and delete the _ReSharper. subfolder of your solution folder.
Let me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

(posted originally in eap forum by mistake)

Since installing 5.1.2, I've noticed several errors flagged by
ReSharper of the following type:

"Argument type A.B.C.D ' is
not assignable to parameter type 'A.B.C.D "

The project builds fine, and this code wasn't flagged prior to
installing 5.1.2.  There is no "Specific Version=true" flag anywhere.
Obviously the types are compatible, so this message seems to be in
error.

Do you know what could be causing this, how to fix it, and if this is
a new bug in ReSharper, or whether something else is going wrong?  Is
there something I can look at that would give you more information, or
help me find and fix the issue of why ReSharper thinks a given type
isn't assignable to itself?

Thanks!



0

Indeed that did seem to fix things... though I had to go hunting because we
keep our Resharper Caches in the system TEMP folder, because having them in
the solution folder was causing issues and slowdowns in our website
solutions (especially with TFS).

Thanks!



"Andrew Serebryansky"  wrote in message
news:c8a898ddbd868cd81fd05cec026@news.intellij.net...

Hello Paul,

Have you tried clearing ReSharper caches? Close all instances of Visual
Studio
and delete the _ReSharper. subfolder of your solution folder.
Let me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

(posted originally in eap forum by mistake)

>

Since installing 5.1.2, I've noticed several errors flagged by
ReSharper of the following type:

>

"Argument type A.B.C.D ' is
not assignable to parameter type 'A.B.C.D "

>

The project builds fine, and this code wasn't flagged prior to
installing 5.1.2.  There is no "Specific Version=true" flag anywhere.
Obviously the types are compatible, so this message seems to be in
error.

>

Do you know what could be causing this, how to fix it, and if this is
a new bug in ReSharper, or whether something else is going wrong?  Is
there something I can look at that would give you more information, or
help me find and fix the issue of why ReSharper thinks a given type
isn't assignable to itself?

>

Thanks!

>

0

Please sign in to leave a comment.