ReSharper annoyances - How to fix?

I've been trying out ReSharper and there are a lot of cool things but a few things about it are annoying me. Was wondering if anyone knew how to resolve these.

1) The size of the new intellisense lists is not limited and can cover up a huge amount of the screen. I often find myself wanting to read some other part of my code while typing and this gets in the way. Especially when it's showing all 16 generic overloads for different numbers of arguments in System.Action.
2) When it auto completes new TypeName, it will add a () at the end. But often I want to use new TypeName { Property1 = 4 } instead. How do I get it to stop this?
3) I like declaring object initializers and not indenting the braces for them (putting them on the same level as an if statement, for example) in order to conserve horizontal space. I checked different braces choices in the options but I didn't find a choice that did this. Anyone know of a way to fix?

5 comments

1) You can just hit 'escape' to dismiss the list, and then bring it back up
if/when you want or need it ... OR you could switch back to VS intellisense
in the ReSharper options.

2) Just type the initializer, then put the cursor on the parens and
shift-Enter to eliminate them (quick fix).  Alternately, you can just do the
"new Typename", let it auto-complete (I actually tend to just type "new typ"
then use the Introduce Variable refactoring to create the full statement.
After hitting enter, type the assignments to initialize the fields, then
position the cursor on the 'new' and use the quick-fix to "user object
initializer".  It'll remove the empty parens, add the curly braces, and
basically do all the heavy lifting for you.

3) ReSharper -> Options, "Braces Layout" section under
Languages->C#->Formatting Style, "Array and object initializer" section,
select "At next line (BSD style)".  Is that not what you want?

"Random Engy"  wrote in message
news:4947424.771271297104685878.JavaMail.devnet@domU-12-31-39-18-36-57.compute-1.internal...

I've been trying out ReSharper and there are a lot of cool things but a few
things about it are annoying me. Was wondering if anyone knew how to resolve
these.

1) The size of the new intellisense lists is not limited and can cover up a
huge amount of the screen. I often find myself wanting to read some other
part of my code while typing and this gets in the way. Especially when it's
showing all 16 generic overloads for different numbers of arguments in
System.Action.
2) When it auto completes new TypeName, it will add a () at the end. But
often I want to use new TypeName { Property1 = 4 } instead. How do I get it
to stop this?
3) I like declaring object initializers and not indenting the braces for
them (putting them on the same level as an if statement, for example) in
order to conserve horizontal space. I checked different braces choices in
the options but I didn't find a choice that did this. Anyone know of a way
to fix?

---
Original message URL: http://devnet.jetbrains.net/message/5285744#5285744

0

1) Well I guess I'll go back to the VS intellisense then.
2) None of those seem as good as standard VS behavior (not autocompleting the parenthesis), but thanks for suggesting.
3) No, it doesn't go far enough to the left.

0

Hi,

You could change completion list size through R# -> Options -> Completion Appearance -> Completion List
Let me know if it helps you.

--
Kirill Falk
.NET Team QA Lead
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

1) I've found that ReSharper intellisense is worth the few quirks.  You get
used to most of them with time, and the few times it's an annoyance, I just
hit escape.  There are also some configuration options that can limit the
size of the list that pops up.  Personally, I'd suggest giving it more of a
chance, but certainly going back to the VS intellisense is an option.  You
just lose a lot of other functionality that way (which I guess you won't
miss if you never use it or don't even know about it).

2) You can turn off auto completing parenthesis in ReSharper if it annoys
you.  Again, this is probably an issue getting used to things, and it's
certainly a good suggestion that ReSharper shouldn't auto-add parens where
they're not necessary.  But there are many solutions here already.  Still,
you could add your suggestion to the Tracker.

3) I guess I don't understand what you mean then.  I did some sample
checking, and it aligns the braces just like I'd expect it to.  If you want
an additional alignment option, simply suggest it in the Tracker.


"Random Engy"  wrote in message
news:11180739.773851297126455359.JavaMail.devnet@domU-12-31-39-18-36-57.compute-1.internal...

1) Well I guess I'll go back to the VS intellisense then.
2) None of those seem as good as standard VS behavior (not autocompleting
the parenthesis), but thanks for suggesting.
3) No, it doesn't go far enough to the left.

---
Original message URL: http://devnet.jetbrains.net/message/5285778#5285778

0

Okay, I've found how to resolve 2 of my issues (thanks, everyone) and I've opened an issue for getting my braces formatting back:

http://youtrack.jetbrains.net/issue/RSRP-213064

0

Please sign in to leave a comment.