PLEASE fix the upgrade experience!

Resharper is an awesome product, but the upgrade experience is just terrible. The uninstall/install cycle is so 10 years ago! I lose settings every time I do an upgrade, not to mention the 10 minutes it takes to uninstall, then install.

PLEASE fix it!

Thanks,
-Jake
Paying Customer.

3 comments

Hello Jake,

loosing settings is not a common problem. I use R# since Version 1.0 and never loosed my settings during upgrade. The time R# needs
for an upgrade depends on the configuration of my PC. Visual Studio 2008 only on Windows XP is quite fast. Visual Studio 2008 and
Visual Studio 2010 on Windows XP takes quite long. The same on Windows 7 is a lot faster.

Normally you won't upgrade so often (except if you participate on the EAP program) so what about 10 minutes for an installation?

If you participate on the EAP program you must consider that you are installing a nightly build which contains debug code. This
means that the setup works slower and has to install more code.

For myself when i come to work in the morning i first look, if there is a new EAP build. If yes i use the multitasking capability of
my PC, download and install the build and meanwhile read my mails or surf in the internet ;)).

Best Regards
Klaus

0

Hello Jake,

Could you please elaborate more information on this problem? Which settings
do get lost? Which were the exact versions you've upgraded from and to? The
installer runs Visual Studio internally in order to complete the installation
correctly and that takes most of the installation time. I'm afraid there's
nothing we can do to make it faster. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Resharper is an awesome product, but the upgrade experience is just
terrible. The uninstall/install cycle is so 10 years ago! I lose
settings every time I do an upgrade, not to mention the 10 minutes it
takes to uninstall, then install.

PLEASE fix it!

Thanks,
-Jake
Paying Customer.
---
Original message URL:
http://devnet.jetbrains.net/message/5287133#5287133



0

If by settings you mean keyboard shortcuts and color scheme this seems to be a known issue, see http://youtrack.jetbrains.net/issue/RSRP-196286 .
(Personally I have to reassign a couple of my customized shortcuts during an upgrade, but not all of them it seems).

0

Please sign in to leave a comment.