Bug? Web References and Service References have wrong InteliSense and Highlighting in Website

I searched the Communitposts and Bugtracker but most similar Problems occured in Resharper 2.x, so maybe its something that only happens in my and my Co-Workers Enviroment.
We use Win7 64Bit, VS2008 and VS2010, Resharper Full Edition 5.1.3000.12

Steps to reproduce the Problem:
- Create a WCF Service
- Create a Website (not a WebApplication!)
- Reference it as Service Reference or Web Reference

With Reshaper Defaultsettings I get no Highlighting and no InteliSense.
If you set Resharper>Options>Intelisense>General to Visual Studio at least InteliSense works - Highlighting still not.

I tried Clearing Cache, Changing Cache location, Deleting Cache Files.. Nothing helps.

Are there other things that I can try to get this to work?

4 comments

Hello Werner,

I wasn't able to reproduce this behavior. Could you please attach a small
sample solution demonstrating this problem? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I searched the Communitposts and Bugtracker but most similar Problems
occured in Resharper 2.x, so maybe its something that only happens in
my and my Co-Workers Enviroment.

We use Win7 64Bit, VS2008 and VS2010, Resharper Full Edition
5.1.3000.12

Steps to reproduce the Problem:
- Create a WCF Service
- Create a Website (not a WebApplication!)
- Reference it as Service Reference or Web Reference
With Reshaper Defaultsettings I get no Highlighting and no
InteliSense.

If you set Resharper>Options>Intelisense>General to Visual Studio at
least InteliSense works - Highlighting still not.

I tried Clearing Cache, Changing Cache location, Deleting Cache
Files.. Nothing helps.

Are there other things that I can try to get this to work?

---
Original message URL:
http://devnet.jetbrains.net/message/5291617#5291617



0

I've attached a zipped up project that illustrates the problem in the DashUserService.svc.cs file.  When you open it in visual studio with resharper it does no analysis, the navigation, and intellisense functions do not work.



Attachment(s):
DashboardGenerator.zip
0

Hello Ben,

ReSharper doesn't work in DashUserService.svc.cs file because that file won't
be compiled when you build your web site. You can add any incorrect code
to that file and the web site will still compile. Let me know if this helps.
Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I've attached a zipped up project that illustrates the problem in the
DashUserService.svc.cs file.  When you open it in visual studio with
resharper it does no analysis, the navigation, and intellisense
functions do not work.

---
Original message URL:
http://devnet.jetbrains.net/message/5291722#5291722



0

That's true that it does compile with the errors.  However, it does give "compile" errors at runtime.  Is it possible for ReSharper to still detect those errors even though they will not be caught at build time?  It's also not just the lack of errors.  It is also a problem that we don't have any navigation support to find usages or go to implementation for a method.

0

Please sign in to leave a comment.