how to un-suppress code inspections

Hi,

I have accidentally suppressed some code inspections (showing "N/A" in Inspection Severity).
Now I would like to have them back (un-suppressed), but how?
(or even better, how to restore the clean right-as-after-install situation regarding this?
I have tried un+re-install but ReSharper appears to remember a lot of things, would like to make it forget)

Thanks!
Andres

3 comments

Hello Andres,

In order to un-suppress the inspection, you can change the setting to anything
other than 'Do not show' under ReSharper | Options | Code Inspection | Inspection
severity. You can also reset all ReSharper settings by removing %APPDATA%\JetBrains\ReSharper\\UserSettings.xml
when none of Visual Studio instances are running. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I have accidentally suppressed some code inspections (showing "N/A" in
Inspection Severity).

Now I would like to have them back (un-suppressed), but how?

(or even better, how to restore the clean right-as-after-install
situation regarding this?

I have tried un+re-install but ReSharper appears to remember a lot of
things, would like to make it forget)

Thanks!
Andres
---
Original message URL:
http://devnet.jetbrains.net/message/5297390#5297390



0

Thank you Andrey!

But after following your instructions, I still feel like something is un-necessarily disabled.
Please see attached image.
Or is it normal what I'm seeing (and why then are things greyed)?

regards,
Andres

typ.gif

0

Hello Andres,

Oh, those inspections are only available when you have solution-wide analysis
turned on. In order to turn it on, check 'Analyze whole solution' under ReSharper
| Options | Code Inspection | Settings. Let me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Thank you Andrey!

But after following your instructions, I still feel like something is
un-necessarily disabled.
Please see attached image.
Or is it normal what I'm seeing (and why then are things greyed)?
regards,
Andres
Image:typ.gif

---
Original message URL:
http://devnet.jetbrains.net/message/5297409#5297409



0

Please sign in to leave a comment.