Inheriting from UserControl : Page_Load method

When creating a class that inherits from System.Web.UI.UserControl it is very common to implement the Page_Load method. However, ReSharper does not like the "_" in the name and is asking me to rename it to PageLoad, which will break the functionality. Is there anyway around this other than littering my classes with resharper disable comments as such?

        // ReSharper disable InconsistentNaming
        protected void Page_Load(object sender, EventArgs e)
        // ReSharper restore InconsistentNaming
        {
             ....
        }

Please sign in to leave a comment.