R#6 Smart Code Completion broken

Yet another R# 6 Intellisense issue, and yet another issue which can only be reproduced in a large solution. :(

I have a .NET 4.0 console project with a code file which only has using statements for System and System.Collections.Generic. I type:

IList<string> test = new

R# "smart" code completion then suggests:

  • two classes from another namespace in my project;
  • System.Collections.ObjectModel.ObservableCollection<T>;
  • System.Collections.ObjectModel.ReadOnlyObservableCollection<T>;
  • System.Runtime.CompilerServices.ReadOnlyCollectionBuilder<T>;


Other classes in my project which implement IList<T> are not suggested. But, more importantly, classes from the BCL in the imported namespaces are not suggested - for example, List<T>!

If I manually type in "List", R# tells me there are no suggestions.

I've tried clearing the caches and deleting both the _ReSharper directory and the .ReSharper.user file, but it makes no difference.

Trying to reproduce this in a new project didn't work. In the new project, R# suggested:

  • one dummy class from my test project;
  • System.ComponentModel.BindingList<T>;
  • System.Collections.ObjectModel.Collection<T>;
  • System.Collections.Generic.List<T> (selected by default);
  • System.Collections.ObjectModel.ObservableCollection<T>;
  • System.Collections.ObjectModel.ReadOnlyCollection<T>;
  • System.Collections.ObjectModel.ReadOnlyObservableCollection<T>;
  • System.Runtime.CompilerServices.ReadOnlyCollectionBuilder<T>;


Is R# 6 seriously not able to cope with projects containing more that a couple of files? Or am I missing the magic flag to make "smart" completion smart enough to suggest types from the namespaces I've already imported?

7 comments

Hi Richard,

did you try to delete R#'s cache on disk? Sometimes this resolves this type of problems.

Regards
Klaus

0

Klaus,

I've cleared the caches from within R#, closed VS2010 and deleted both the "_ReSharper.ProjectName" directory and the "ProjectName.6.0.ReSharper" file. It doesn't make any difference.

Regards,
Richard

0

I've managed to reproduce both the "ArgumentNullException" and the  "List<T>" problems on a stripped-down version of my solution,  running on a clean PC with no other extensions or add-ins installed.

I've sent a zipped copy of the solution to Andrey, so I hope he should be able to reproduce it soon.

0

I see the exact same behavior in a large solution that I'm working on.

0

Awesome, when's R# 6.1 due? :)

0

No idea. There's still no sign of an EAP for 6.1, so I'm guessing it's at least a couple of months away.

0

Please sign in to leave a comment.