Memory usage is killing me

I'm running VS2010 on Win2008 R2 on Parallels and it's eating memory like crazy with Resharper 6.0.  The vm has 4gb available, if I don't manually close and restart Visual Studio every 20 minutes or so I have to force-close it from the task manager.

As soon as I open a project it goes up to a couple hundred meg of ram while it does all the initial stuff, and then it increases at a few hundred kilobytes a second until everything grinds to a halt.

If I suspend Resharper then I can use VS indefinitely without having problems, although it doesn't actually release the memory it just stops using more.

Any suggestions?

17 comments

Hello Ben,

Do I understand correctly that the memory usage increases by itself, while
you're doing nothing with Visual Studio? Does this happen even when no solutions
are opened in Visual Studio? Also, could you please turn on 'Show managed
memory usage in status bar' option under ReSharper | Options | General and
monitor how managed memory usage changes over time? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm running VS2010 on Win2008 R2 on Parallels and it's eating memory
like crazy with Resharper 6.0.  The vm has 4gb available, if I don't
manually close and restart Visual Studio every 20 minutes or so I have
to force-close it from the task manager.

As soon as I open a project it goes up to a couple hundred meg of ram
while it does all the initial stuff, and then it increases at a few
hundred kilobytes a second until everything grinds to a halt.

If I suspend Resharper then I can use VS indefinitely without having
problems, although it doesn't actually release the memory it just
stops using more.

Any suggestions?

---
Original message URL:
http://devnet.jetbrains.net/message/5321228#5321228



0

Hi Andre,

With no solutions open the memory usage is stable at ~100 megabytes.

After opening a solution memory increases at ~300 kilobytes/second without doing anything and with or without code files open.

After closing the solution the memory use does not grow anymore.

Memory usage samples over the last 10 or 15 minutes:

VS 348mb / RS 75.2mb

VS 373mb / RS 76mb

VS 386mb / RS 76.2mb

VS 400mb / RS 76.6mb

VS 420mb / RS 77.5mb

VS 430mb / RS 77.8mb

VS 440mb / RS 78.2mb

VS 450mb / RS 78.3mb

They're both steadily increasing although not at the same rate.

Ben

0

After another ~10 minutes VS is on 700mb and RS on 93.4mb.

0

Restarted after lunch, did some C# and JS editing but mostly left it idling, it's now on VS 1,520mb / RS 163.

0

Hello Ben,

Thank you for this information! Could you please check if this happens only
with a particular solution or with any solution opened?

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Restarted after lunch, it's now on VS 1,520mb / RS 163.

---
Original message URL:
http://devnet.jetbrains.net/message/5321275#5321275



0

Yeah I can see the same memory increases happening on all of my solutions, they cover C# services and command line utils, websites, and supporting libraries.

Ben

0

Hello Ben,

Could you please check if this happens if you create a brand new solution
with a new class library in it as well? Also, are you using any plug-ins
for ReSharper? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Yeah I can see the same memory increases happening on all of my
solutions, they cover C# services and command line utils, websites,
and supporting libraries.

Ben

---
Original message URL:
http://devnet.jetbrains.net/message/5321335#5321335



0

On a new solution it's working great.

I don't have any plugins installed.

0

I have more or less same issues.

Opening my Generic Handler file resulted in instanous 60% CPU usage of "devenv.exe" process, and memory rising ~200MB each second, until eventually no more memory was available and Visual Studio 2010 stopped working.

No issues after uninstalling RS 6.0. Now I'm going back to RS 5.1 ;)

0

Hello Ben and Kristian,

It seems that this problem is solution-related. Could you please strip down
your original solutions to small sample ones that exhibit the same behavior
and send them to andrew dot serebryansky at jetbrains dot com? This would
really help us to investigate and fix this problem. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have more or less same issues.

Opening my Generic Handler file resulted in instanous 60% CPU usage of
"devenv.exe" process, and memory rising ~200MB each second, until
eventually no more memory was available and Visual Studio 2010 stopped
working.

No issues after uninstalling RS 6.0. Now I'm going back to RS 5.1


---
Original message URL:
http://devnet.jetbrains.net/message/5321400#5321400



0

I might have found out why the memory is acting up in Resharper 6.x.

It may be because Solution-wide Analysis was re-enabled after installing the new resharper. I remember it being turned off when I had 5.x installed.

I will post more when I have thoroughly tested this.

0

Hello Ben,

Thank you for the sample! I was able to reproduce this behavior with ReSharper
6.0, but could not reproduce it with v6.1, so most likely this problem is
already fixed and you're welcome to try ReSharper 6.1 EAP when the first
build comes out.

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Sent.

Ben

---
Original message URL:
http://devnet.jetbrains.net/message/5321471#5321471



0

Did not help... I'm waiting for a new version of Resharper, or I'll have to stick with 5.1 forever :)

0

Is there an easy wa yto downgrade down to 5.1?

0

Please sign in to leave a comment.