NUnit Runner marks all tests as Ignored

Hi,

I have a solution with a couple of NUnit test projects in it, and for one of the projects the Resharper NUnit test runner marks all of the tests as ignored.
The same solution checked out of a different branch works just fine on the same machine, and the tests do not have the [Ignore] attribute attached.
The only clue is that the very first time I try running the unit tests after opening the solution I get a dialog box saying "Cannot analyse project output. The file does not exist.". That is the whole message, no file paths or any other information.

I tried everything I could think of, and even re-booted the machine out of desparation. Any ideas?

=================================================================

JetBrains ReSharper 6.0 Full Edition
Build 6.0.2202.688 on 2011-06-30T04:14:16

License server at http://vcvansftp2.vci.local:8080/licenseServer is used
Plugins: 1
#1. “AgUnit 0.4.2 for R# 6.0” v0.4.2.0 by “AgUnit authors - http://agunit.codeplex.com”
Visual Studio 10.0.30319.1.

Copyright © 2003–2011 JetBrains s.r.o. All rights reserved.

4 comments

Hello Martin,

What happens if you run those same tests using the original NUnit console
runner? Could you please also run Visual Studio (devenv.exe) with /ReSharper.LogFile
"C:\log.txt" /ReSharper.LogLevel Verbose command line parameters, run the
tests, make sure they show up as ignored and attach the resulting log.txt
file here? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I have a solution with a couple of NUnit test projects in it, and for
one of the projects the Resharper NUnit test runner marks all of the
tests as ignored.

The same solution checked out of a different branch works just fine on
the same machine, and the tests do not have the attribute
attached.

The only clue is that the very first time I try running the unit tests
after opening the solution I get a dialog box saying "Cannot analyse
project output. The file does not exist.". That is the whole message,
no file paths or any other information.

I tried everything I could think of, and even re-booted the machine
out of desparation. Any ideas?

=================================================================
JetBrains ReSharper 6.0 Full Edition
Build 6.0.2202.688 on 2011-06-30T04:14:16
License server at http://vcvansftp2.vci.local:8080/licenseServer is
used
Plugins: 1
#1. "AgUnit 0.4.2 for R# 6.0" v0.4.2.0 by "AgUnit authors -
http://agunit.codeplex.com"
Visual Studio 10.0.30319.1.
Copyright © 2003-2011 JetBrains s.r.o. All rights reserved.

---
Original message URL:
http://devnet.jetbrains.net/message/5320840#5320840



0

Everything works as expected in the original NUnit console.
I uninstalled ReSharper 6 and re-installed ReSharper 5, and this immeditely fixed the problem.

0

Hello Martin,

It would be great if you could create a small sample solution out of the
original one (by removing projects and files while keeping this problem reproducible)
and attach it here, so that we could investigate this problem on our side?
Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Everything works as expected in the original NUnit console. I
uninstalled ReSharper 6 and re-installed ReSharper 5, and this
immeditely fixed the problem.

---
Original message URL:
http://devnet.jetbrains.net/message/5320924#5320924



0

Please sign in to leave a comment.