License Server

Hi, we're evaluating the License Server application to manage licenses for several of your products within my company. Is this the suggested approach? I couldn't figure out whether the License Server is an officially supported product.

9 comments
Comment actions Permalink

Hello Simone,

The License Server (http://confluence.jetbrains.net/display/LS/Home) is the
official application for centralized license management for JetBrains products.
Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi, we're evaluating the License Server application to manage licenses
for several of your products within my company. Is this the suggested
approach? I couldn't figure out whether the License Server is an
officially supported product.

---
Original message URL:
http://devnet.jetbrains.net/message/5279167#5279167



0
Comment actions Permalink

I've tried to set up the license server but I'm having issues with autodiscovery. Without autodiscovery everything is working fine, but as soon as I enable it (on R#) I get the message:

Error occurred while connecting to license server: The remote name could not be resolved: 'jetbrains.license.server'.

Here is the dig query, which looks fine:

; <<>> DIG <<>> _jetbrains-license-server.domain.name TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16247
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;_jetbrains-license-server.domain.name. IN TXT

;; ANSWER SECTION:
_jetbrains-license-server.domain.name. 3600 IN TXT "url=[http://server-url:8080/licenseServer]"

0
Comment actions Permalink

Hello Simone,

Could you please attach a screenshot of the 'Error occurred while connecting
to license server' message? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I've tried to set up the license server but I'm having issues with
autodiscovery. Without autodiscovery everything is working fine, but
as soon as I enable it (on R#) I get the message:

Error occurred while connecting to license server: The remote name
could not be resolved: 'jetbrains.license.server'.

Here is the dig query, which looks fine:

; <<>> DIG <<>> _jetbrains-license-server.domain.name TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16247
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL:
0
;; QUESTION SECTION:
;_jetbrains-license-server.domain.name. IN TXT
;; ANSWER SECTION:
_jetbrains-license-server.domain.name. 3600 IN TXT
"url=[http://server-url:8080/licenseServer]"
---
Original message URL:
http://devnet.jetbrains.net/message/5281145#5281145



0
Comment actions Permalink

Hi Andrey, here it is.



Attachment(s):
license.png
0
Comment actions Permalink

Hello Simone,

The 'jetbrains-license-server' is the default server name that is used by
ReSharper if it failed to find any other license server urls. The dig record
looks fine to me, however do I understand correctly that you've run dig on
the same machine with ReSharper that gives this error message and you got
the same output as above? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Andrey, here it is.

---
Original message URL:
http://devnet.jetbrains.net/message/5281282#5281282



0
Comment actions Permalink

Exactly, I run dig (for Windows) on the same machine which has R# installed, and I cannot guess why the dig answer is fine while R# keeps having troubless connecting to the license server.
Furthermore, I tried putting a DNS query sniffer (Wireshark) intercepting the DNS query which R# is doing when I enable autodiscovery and click OK, and to me the everything looks fine (screenshot attached).



Attachment(s):
wireshark.png
0
Comment actions Permalink

Hello Simone,

It looks like there's no need to have square brackets in the record. That
is, wireshark should display something like:

Text: url=http://

:8080/licenseServer


instead of

Text: url=[http://:8080/licenseServer]

Let me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Exactly, I run dig (for Windows) on the same machine which has R#
installed, and I cannot guess why the dig answer is fine while R#
keeps having troubless connecting to the license server.

Furthermore, I tried putting a DNS query sniffer (Wireshark)
intercepting the DNS query which R# is doing when I enable
autodiscovery and click OK, and to me the everything looks fine
(screenshot attached).

---
Original message URL:
http://devnet.jetbrains.net/message/5281294#5281294



0
Comment actions Permalink

Exactly, removing the square brackets fixed it. The docs are a bit misleading, thank you very much for your support.

0
Comment actions Permalink

I've got absolutely the same issue
Capture1.PNG
but in my case I don't see with wireshark any attempts to resolve _jetbrains-licence.server.domain.com from DNS server.
Of course url doesn't contain square brackets.

response from DNS server (Windows based) looks like

dig _jetbrains-license-server.domain.com TXT

;; ANSWER SECTION:
_jetbrains-license-server.domain.com. 3600 IN TXT "url=http://lic.domain.com:8080/licenseServer"



VS2010, Resharper 6.1, License server build 288

Any ideas?

0

Please sign in to leave a comment.