Resharper and Microsoft Productivity Power Tools

I'm using both Resharper and Microsoft's "Productivity Power Tools" for Visual Studio 2010.


http://visualstudiogallery.msdn.microsoft.com/d0d33361-18e2-46c0-8ff2-4adea1e34fef


For the most part, they play nice together, but there is one bit of wierdness.  When resharper shows an error in red, and I apply resharper's suggestion to fix the error (either with mouse, or alt-enter,enter), while the error is gone, the syntax is still highlighted with the same red coloring.  In order to fix the coloring, I have to cut and paste the line of text back over itself.

Is this a resharper bug, or a bug with the power tools extension, or something in visual studio itself?


Thanks,
-Matt

6 comments
Comment actions Permalink

Hello Matt
     Do you seen an error mark on ReSharper's error stripe after you've fixed the error and the syntax is still highlighted with red? Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

No.  Resharper shows it green, but I still have the red squiggle underline in the UI and a red mark in the scrollbar area from the powertools plugin.  It's like Resharper is re-evaluating it but then the powertools plugin is not.  I don't know if resharper is blocking it, or what.

0
Comment actions Permalink

Now that I've been experiencing it for awhile, I will change the answer the last question.  Usually, YES, the yellow or red mark in resharper's right-side bar is still there.  Sometimes, it is not.  It manifests differently depending on exactly what I'm doing. But I would say 80% of the time, the error marks show both in the text editor and in resharper's bar, even after the error or warning has been resolved.

Any idea what's going on here?  I like the extra stuff in the productivity tools but, it's really annoying that it doesn't play nice with resharper.

-Matt

0
Comment actions Permalink

Hello Matt
     Have you noticed any particular scenario where this happens 100% times? It would be great if you could find such repro case, so that we could investigate this behavior on our side. Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

I also experience this from time to time with an old highlighting not going away even after the problem is resolved (this is not specific to errors), with a marker in ReSharper bar that has en empty tooltip on hover. When it happens with errors, solution wide analysis correctly report no error but the file still shows one.
I DON'T have productivity power tools installed so it seems to be unrelated. I never managed to get a constant repro so far.

0
Comment actions Permalink

I've had this happen as well (without the productivity tools)..  usually it seems it's after I've had the IDE open for a while* and having a lot of open file tabs... I'll try to pay more attention to it..

* might be days

0

Please sign in to leave a comment.