"cannot launch debugger" in a unit test error code -1989083114

hi,

i hope no one laughs that I am using Visual Studio 2005 in this case (historical reasons.)

Generally i am getting happier with R# every day. today i ran into this problem, however:
  "cannot launch debugger" error code -1989083114

i'm trying to debug a unit test. incidentally, i can run all the unit tests.

(I think the problem is new / recent. that is, i think until fairly recently I was able to debug in a unit test in this setting.)

i'm using
  MS Visual Studio 2005 Version 8.0.50727.867
and
  R# 6.1 Build 6.1.37.86

i'd be grateful for any ideas how to fix this or get around it.

cheers,

Tim

6 comments
Comment actions Permalink

Hello Tim
     Which unit test framework do you use? Are you able to debug applications and attach debugger to a .NET process using Visual Studio? Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Thanks, Andrey,

> Which unit test framework do you use?

NUnit 2 something (the stable version as of roughly last summer); i will find the exact version and see if a newer version helps. (do you know a quick way to ask NUnit what version it is?)

> Are you able to debug applications and attach debugger to a .NET process using Visual Studio?

yes. the solution in question consists of quite a number of projects, about 20 in all. i'm mainly concerned with developing about 7 libraries, but there are quite a number of console application projects (which typically use the libraries) as well. so far i've had no trouble debugging, e.g. by making the start-up project one of the console projects that uses all the libraries, and debugging "normally" with debug/start.

cheers,

Tim

0
Comment actions Permalink

Update, alas, still no happy conclusion.

I revisited this today and tried a number of straightforward measures (btw, i'm running this IDE under Windows 2008 Server - for peculiar historical reasons):

  • Software Repair R#
  • Software Change R#
    • remove support for VS2005
    • re-include support for VS2005
  • (sanity check: unit test debugging still works in VS2008)
  • Software Repair VS2005 (took a LONG time and needed to start back at square one after noticing i needed to close Sql Mgmt Studio :()
  • second sanity check: created a new almost empty solution / project with just one TestFixture class and one test -- can't debug that unit test either


should i try to migrate this solution to VS2008 ? (probably more trouble than it's worth as this solution is stabilizing and close to its end-of-life.)

cheers,

tbh

0
Comment actions Permalink

I have exactly the same problem in VS2005 on a system where also VS2010 is installed.
On another system (where no VS2010 is additionally installed) I cannot reproduce this issue in VS2005 with the same solution.
The error seems to be new in 6.1., I've seen it for the first time after an upgrade to 6.1.1000.82, which I use.

Update:
I found the following workaround which solved the issue for me:

In %ProgramFiles%\JetBrains\ReSharper\v6.1\Bin\JetBrains.ReSharper.TaskRunner.CLR4.MSIL.exe.config
I replaced:
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <requiredRuntime version="v4.0" />
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
  </startup>

with:
   <startup>
      <supportedRuntime version="v2.0.50727"/>
   </startup>


Additional information:
.NET RunTime version of my project is: v2.0.50727
At the machine on which the error occurs is .NET 4.0 installed, at the other one .NET 4.0 is not installed.

0
Comment actions Permalink

Hmm, I have exact same problem, with same exact versions (VS2005 and R# 6.1)

Additional info:
1. I can run nunit tests from R# just fine
2. I am running in a VM, and accessing project (source and dlls) on my host machine, via a mapped drive.
3. My OS is Win7 (both guest and host)

This is a new installation. In my old machine (XP) where I was not using a VM, it worked fine.

-Dave

0
Comment actions Permalink

Thanks, Matthias!

your work-around works for me too.

i haven't been working in this old solution much, but revisited it now. good to know i can debug unit tests again - a huge help in many cases.

cheers,

Tim

0

Please sign in to leave a comment.