Excessive Memory Usage/Leak when debugging in VS2010 & VS2012 with RS7

This issue had nothing to do with Resharper. Managed to isolate the problem.

---------------------------------------------------------------------------------------------

When I am debugging a WCF service using either VS2010 or VS2012 the memory usage skyrockets with Resharper 7

Normally the project hovers around 1GB when debugging with RS6 but now it seems to go above 2GB and rising especially when reentering the service.

I have uninstalled Resharper and now the memory usage is at 500MB when debugging.

I have Resharper 7.0.1

Is there some way to get a better idea of where the memory is going, do I need to use the memory profiler?

Thanks

David

Message was edited by: David Wong

3 comments
Comment actions Permalink

Hello David
     Thank you for reporting this problem! Could you please try gathering a memory snapshot by following the instructions here: http://confluence.jetbrains.net/display/ReSharper/ReSharper+Profiling+Instructions ?

Andrey Serebryansky

Software Developer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Sorry I have managed to isolate and track down the issue and it has nothing to do with Resharper.

My next culprit is .NET 4.5 :)

0
Comment actions Permalink

Thank you for letting us know! Great that it wasn't ReSharpers fault.

________________________
Alex Berezoutsky,
Senior Support Engineer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

Sorry I have managed to isolate and track down the issue and it has
nothing to do with Resharper.

My next culprit is .NET 4.5

---
Original message URL:
http://devnet.jetbrains.net/message/5467942#5467942



0

Please sign in to leave a comment.