Minor problems after upgrade to R# 7.1

Hi,

I've just upgraded my development PC to use R# version 7.1.25.234.  It has VS2010 and VS2012 installed on it.  Neither version was running when I performed the upgrade.

After the upgrade I opened just VS2012.  When it opened, I got TWO test runner windows, one using the VS2012 style, the other using the VS2010 high-colour-nice-icons style.  I closed both of these windows.  Now when I run unit tests, I get a single test runner window, but it is STILL using the VS2010 style.

Has anyone else seen this behaviour?  How do I sort this out so that I get the correct test runner?

Prior to the upgrade I was running version 7.0.1098.2760 without any issues.

11 comments
Comment actions Permalink

Hello David,

Could you please provide some screenshots of what you're talking about? Thank you in advance!

0
Comment actions Permalink

Here are some screen-shots:

Vs2012WithTwoTestRunners.png shows what I get when I start VS2012 - (I've moved and resized the two
test session windows to reduce the size of the image).

I then closed both of the test session windows.

Vs2012RunningTestsInATestFixture.png shows what I get when I run tests from a fixture using the button in the LH margin of the source file containing the fixture class.  Notice that the test session window style is the high-colour detailed-icon style that you get when running R# in VS2010.

I closed the test session window.

Vs2012_ReSharper_UnitTests_UnitTestSessions.png shows what I see if I bring up a test session window using the ReSharper menu.  Notice that this test session window has the correct colouring and styling to match the rest of VS2012.



Attachment(s):
Vs2012_ReSharper_UnitTests_UnitTestSessions.png
Vs2012RunningTestsInATestFixture.png
Vs2012WithTwoTestRuners.png
0
Comment actions Permalink

Hi,

after upgrading I had exactly the same problem with the two windows (see screenshot Resharper71.png), also the nunit test menu appears inverted (NUnit.png).

best regards
Thomas



Attachment(s):
Resharper71.PNG
NUnit.png
0
Comment actions Permalink

Hello Thomas and David,

It appears that you have both ReSharper and dotCover Unit Test Runners active. Please try to disable dotCover Unit Test runner in "dotCover | Options | Unit testing" dialog, uncheck the "Enable Unit Testing" checkbox.

Please let me know the results.
Thanks.

0
Comment actions Permalink

Hi Alex,

that helped indeed...
does it mean dotCover is currently not integrating correctly?

Thanks for your quick response
Thomas

0
Comment actions Permalink

Hi Thomas,

I think the real issue is with the checkbox state for dotCover Unit Test Runner - it wasn't succesfully updated for some reason while installing ReSharper 7.1.

Thanks.

0
Comment actions Permalink

I've tried what you suggested.  It does indeed remove the colourful version, but it takes away all of the dotCover context menu options as well.

I have instead disabled the ReSharper unit test runner and left the dotCover runner enabled.  This way I get just the colourful runner, but I can still use dotCover and run unit tests.
I guess that this problem isn't going to go away until a newer version of dotCover is released.

0
Comment actions Permalink

Hi David,

Please try dotCover 2.2 EAP for this and let me know if it's working fine for you or not: http://confluence.jetbrains.com/display/DCVR/dotCover+Early+Access+Program.
Thanks!

0
Comment actions Permalink

Much better!

With dotCover 2.2 everything works as expected.
I have the ReSharper unit test runner enabled and the dotCover unit test runner disabled.

I now get one runner on startup.
The context menus now contain the dotCover items, even with the dotCover unit test runner disabled.
The test runner that appears contains both the unit test results and code coverage tabs.

Result!

0
Comment actions Permalink

Thank you for the awesome news, David!

0

Please sign in to leave a comment.