Unit test does not run in correct folder with ReSharper7.1

I got this problem http://devnet.jetbrains.net/message/5470816 last week,so I upgraded ReSharper to 7.1, but I found that System.Environment.CurrentDirectory in unit test got a path like "C:\Users\myusername\AppData\Local\Temp\TestResults\myusername_mycomputername 2012-12-04 20_43_11\Out\" but not the project output folder.

This is my setting. Is there any mistake?
QQ截图20121204204514.png

2 comments
Comment actions Permalink

I changed Test Run Configuration to "default" and the problem was solved.

0
Comment actions Permalink

Do have the same problem here. Using ReSharper 7.1.25.234.

Tried the given solution by putting "Use this Test Run Configuration" to default.
But it will not save my change. If I reopen the configuration screen, the setting points again to the existing local.testsettings file.
The original VS2012 testrunner needs this file to find all the assemblies, so I can't delete this file.

To the moderator: this tread was tagged as answered. Should I start a new one?

0

Please sign in to leave a comment.