Unit Test Explorer does not recognize Unit Test Categories

We are using the following:
JetBrains ReSharper 8.0.1 Full Edition
Build 8.0.1000.2286 on 2013-09-05T16:18:00

Plugins: 1
#1. “NuGet support for ReSharper” v1.3.0.28776 by JetBrains
Visual Studio 10.0.40219.1.

Copyright © 2003–2013 JetBrains s.r.o. All rights reserved.

When we open the solution the Unit Test Explorer does not split unit tests up by their categories. We have the group by set to Category but all tests regardless of category are grouped into Uncategorized. This is very inconvenient as we have some very slow tests categorized as Extended so that the developer does not have to always run those tests. But ReSharper is not allowing the developer to distinguish between the two different categorized tests. This issue came about in ReSharper 8. Is anyone else experiencing this? Will this be fixed in ReSharper 8.0.2?

Thanks,
Damien



Attachment(s):
Unit test categorization.png
2 comments

Hi Damien,

Please try out ReSharper 8.0.1 and check if it helps: http://www.jetbrains.com/resharper/download/index.html

Let me know the results.
Thanks!

0

This is happening with ReSharper 8.0.1 build 8.0.1000.2286. When we load the solution for the first time all tests are categorized as Uncategorized as shown in the screen capture. Once you run all tests then tests are correctly categorized, until you close the IDE. Once you start the IDE again then you have to run all tests again to have the test categorized correctly. This has only come about since the inception of ReSharper 8 EAP. It's very annoying.

0

Please sign in to leave a comment.