Resharper encoding (Codepage 1252) when creating a class

When I use the Resharper shortcut Alt+ Ins to create a class it creates a file with the encoding Western European Codepage 1252 whereas if I create a new class using the VS2008 wizard it creates it with the UTF-8 Codepage 65001 encoding.  Is there a way for me to configure Resharper to use the same encoding as VS2008 as otherwise we get Stylecop/merge issues.

4 comments
Comment actions Permalink

Hello
Is it any solution for this? I again stuck with this.
The files created by resharper has different encoding. I want always use UTF-8 with signature. Is there any way to set resharper in that way?

Currently using option to e.g. move types to matching files is pain. Espesially when I have a lot of types there. I have to go to each generated file and manually fix encoding.

0
Comment actions Permalink

Has anyone solved this problem?

0
Comment actions Permalink

+1

This is pretty annoying. I do not want to use GIT to (auto-) convert my source files using UTF8(with BOM) encoding.

0

Please sign in to leave a comment.