Jasmine tests always pending

I am trying to create a POC for Jasmine testing and have copied in the default jasmine tests from the jasmine 2.0 download and put them into a solution as per the screenshot. Whenever I run the tests (in browser or using PhantomJS) they are all on pending and never run.


I have also tried referencing jasmine in the spec file but that doesn't work either.

So far I cannot get any tests to run.

Using:

Jasmine 2.0
VS 2013 ultimate
PhantomJS 1.9.7
R# 8.1


Please help!

Thanks,
Maurice



Attachment(s):
Capture1.PNG
Capture.PNG
5 comments
Comment actions Permalink

Sorry i can't help you, because i have exactly the same problem :-(

0
Comment actions Permalink

I found this issue the other week, I eventually tracked the problem down to the fact that I had downloaded jasmine version 2 and included the <reference> tag at the top to it which does not work in version 2 because the way jasmine is initialised has changed.

I am not sure if this is your issue (if you remove the direct <reference> tag or change it to point at a 1.* version of jasmine and see if that works)

Does anyone know if Resharper plan on supporting Jasmin 2 soon or if there are any nice alternatives in the mean time?

0
Comment actions Permalink

Hi Kelvin, thanks for your reply.

Yep that the problem :) At least the test will run when removing the reference :)

Let's hope they fix it pretty soon, annoying bug.

0
Comment actions Permalink

I've downloaded the latest version of the eap resharper and it seems that when you enable jasmine you can select which version you would like to use and then after this you can include the correct reference at the top of the test files.

So it seems that jasmine 2 support is not far away!

0
Comment actions Permalink

Thanks for the tip, ill have to try it.

I wonder why Jetbrains has a @resharper twitter account, because they do not seem to read it or reply on questions :(

0

Please sign in to leave a comment.