Highlight usages of selected word

Hello, I'm using Resharper with VS2010 and want to have VS highlight all the occurances of the word I have highlighted.  Currently if I simply click on a word, I see that the other occurances get highlighted a very light grey, but I'm not sure if that's a VS feature or Resharper.  I read that in Resharper, hitting CTRL+SHIFT+F7 will highlight the usagaes, but when I hit that key combination, nothing is happening.

http://www.jetbrains.com/resharper/webhelp/Navigation_and_Search__Finding_Usages__Highlighting_Usages_in_File.html

My keyboard mapping scheme in VS is set to "Default" and almost all of the Resharper shortcuts work.  Where can I see each shortcut mapping and verify or set the CTRL+SHIFT+F7 to make it highlight the usages.  I believe I can then go into the VS options for fonts/colors and change the highlight color for this, but I'm not sure what option that would be either (as I'd like to use a green color).

Any help would be greatly appreciated.  Thank you.

Kindest Regards,
Nelson

3 comments
Comment actions Permalink

Could you please specify what keyboard scheme is selected here ReSharper | Options | Environment |  Keyboard & Menus | ReSharper keyboard scheme?

Also please have a look what shortcut is mapped to "ReSharper.ReSharper_HighlightUsages" action here Tools | Options | Environment | Keyboard | Type the action name in "Show commands containing" field | Look at items in "Shortcut for selected command" dropdown.

0
Comment actions Permalink

Hi Alexander, thank you for the prompt reply.  The keyboard scheme in Resharper -> Options -> Keyboards & Menus is set to Visual Studio (as these are the shortcuts that I'm used to) - but most all of the Resharper ones do seem to work with this schema set.  Is this incorrect?

The ReSharper.Resharper_HighlightUsages is set to Shift+Alt+F11, which when I try to use that it says it's already mapped to a VS shortcut for debug into (which I'd like to retain).  Perhaps I can change this to Ctrl+Shift+F7 here as I do not believe that is being used for anything (at least it's not doing anything when I try it).  Also where may I change the color for the HighlighUsages?

Thank you again for your time.

Regards,
Nelson

0
Comment actions Permalink

Hello Nelson!

Just to have a correct shortcut showing in webhelp, please change the value in "Keyboard shortcut layout" here http://www.jetbrains.com/resharper/webhelp/Navigation_and_Search__Finding_Usages__Highlighting_Usages_in_File.html as demonstrated on the attached screenshot.

If you would like to keep VS action for Shift+Alt+F11 shortcut, you may map any other one for ReSharper.Resharper_HighlightUsages in Tools | Options | Environment | Keyboard.

Regarding colors: Please try changing "ReSharper Read Usage", "ReSharper Write Usage" and "ReSharper Highlight Target" display items for Text Editor in Tools | Options | Environment | Font and Colors.



Attachment(s):
Keyboard_shortcut_layout.png
0

Please sign in to leave a comment.