Confused over settings layers

We have a "global" R# settings file in TFS, and recently had a new developer start in the team. He got the settings file out of TFS and added it as a new layer below "This Computer" in the Settings Layers dialog. However the changes didn't take effect.

As an example, our "global" settings file changes the "Instance fields (private)" naming convention to be "_lowerCamelCase" (underscore at start). Looking through each layer on the new guy's PC, it was still displaying the default ("lowerCamelCase") in these layers: "Solution ... personal", "Solution ... team-shared", and "This computer". Only the newly added layer (beneath "This computer") showed the customised setting of "_lowerCamelCase", but why isn't this custom setting taking effect?

(The only way I could get our global settings to take effect was to *import* the file into "My computer", but this defeats the object of having a "global" file in TFS. If I make changes to it in the future, I want other devs to do a "get latest" and have the modified R# settings take effect straight away).

I'm using v8.1 by the way.

2 comments
Comment actions Permalink

Could you please attach here the following screenshots of:

  • ReSharper | Manage Options;
  • "Code Editing | C# | Naming Style" option page for each layer in Manage Options?
0
Comment actions Permalink

Hi

I've attached the "manage options" dialog, and the settings for our global company settings (the options that is a child of "This computer").

I haven't attached the other settings screenshots - as mentioned in my question we found a workaround to resolve the issue, so the screenshots won't reflect the settings when we had the issue. The only thing I would say is that the "Instance fields (private)" setting appeared as "lowerCamelCase" in all three of those settings files (when in fact we wanted it to be "_lowerCamelCase" as per the global settings file). Unfortunately I can't remember if it appeared "greyed out" or not when we had the issue.

(Thinking about it, the only thing we didn't try was to close and restart VS after adding the global settings. Perhaps that was the problem?)



Attachment(s):
resharper_company_settings.jpg
resharper_manage_options.jpg
0

Please sign in to leave a comment.