Resharper shooting up disk performance

Hello All, I have a solution which has around ~100 projects. Resharper works well with this solution. But if i leave the VS idle for a while or switched to differnt app and switch back to VS the IO shoots up
The processmonitor says huge number of events on these files
  C:\Users\USERNAME\AppData\Local\Temp\ReSharperCache\_ReSharper.ProjectName.ID\CACHES_FORMAT_VERSION
  C:\Users\USERNAME\AppData\Local\Temp\ReSharperCache\_ReSharper.ProjectName.ID\PersistentCaches


Any idea what could have gone wrong? I tried deleting the cache aswell and it did not help either. Any help would be appreciated.
1 comment
Comment actions Permalink

The IO you can see is ReSharper building the cache, which is used to speed up navigation, as well as many other aspects of ReSharper (e.g. faster cross file/project renames). If the cache isn't there, ReSharper will recreate it the next time you open the solution. Once the cache is built, however, it needs minimal work to keep up to date, as you're usually only changing a single file at a time, so you can just leave it to create the cache. However, it shouldn't take too long to build the cache. There are two things you can do here, that might help:

1. It looks like your cache is in %TEMP%. If you're clearing temp on a regular basis, the cache will need to be recreated more frequently. Try not to delete the cache regularly. You can change the location of the cache in the ReSharper options dialog -> Environment -> General. A good location is either in the solution folder, or under the user local settings folder.

2. Check to see if you have turned on solution wide error analysis. This is a further cache that gathers much more information and performs standard ReSharper analysis on all files, not just visible files. Given the size of your solution, this will have a noticeable impact while it's building the extra cache information. Again, once the cache is built, it should have minimal IO impact (although it will have an impact on memory usage). You can disable this for the project from the ReSharper -> Inspect -> Solution Errors Window.

0

Please sign in to leave a comment.