Can not use "Explore Type Hierarchy" with Resharper SDK

Hi,

After using the MSI install for the Resharper SDK and created a new project that creates the "reverse string" project. I started reading the documentation and got stuck on section #3

Here: http://confluence.jetbrains.com/display/NETCOM/3.01+Type+System+%28R8%29

It says I should be able to browse the type hierarchy of the SDK types to learn more about those types, but when I try to do this Visual Studio says "The key combination (Ctrl+E, H) is bound to command (Resharper_TypeHierarchy_Browse) which is not currently available".

When I use "Explore Type Hierarchy" on my own projects it works fine, but does not work with any of the SDK types.

Looking at the SDK DLL files there are no PDB files, which I assume is required for the Resharper feature to work.

Can anyone clarify how to get this to work as described in the manual.

Thanks,

3 comments
Comment actions Permalink

Is anyone able to use Explore Type Hierarchy on the SDK? I'm still not able to get it to work.

0
Comment actions Permalink

Success!

I got it working finally.

I had to change my project settings to build for .NET 4.5, and then the Hierarchy window would open. After that I had to turn off "Show Elements from this Solution" to see types from the SDK.

Can anyone comment on why this fixed it?

0
Comment actions Permalink

Well, that fixed Explore Type Hierarchy, but now ReSharper stopped working in Visual Studio for that plugin project?

Switching back to .NET 4.0 fixed that problem, but again Explore Type Hierarchy is broken again.

I give up....

0

Please sign in to leave a comment.