AppSettings and DLLs not found running unit tests

Hi,
I have just completed upgrading my OS, Visual Studio and Resharper. After the upgrade, the Resharper unit test runner exhibits too behaviours:

1) It intermittently complains about a DLL not being found. This occurs when as soon as I click the button to "Run All Tests in Solution". A dialog box appears stating that the FluentNHibernate dll could not be found. Rebuilding or running individual projects instead of the entire solution sometimes fixes the issue, sometimes not.

2) Tests that rely on appSettings or other app.config settings fail due to the settings not being present. However the settings are most definitely present. When running individual projects instead of the entire solution the problem does not occur.

My old setup was: XP (x86), Visual Studio 2010, Resharper 6.1.
I have migrated to: Windows 8 (x64), Visual Studio 2013 Update 3, Resharper 8.2.2.

I have changed all my project properties to run as x86, rather than "Any CPU". In the unit test runner console, I have specified the Platform as x86.

I'm 99% sure that I am not doing any tricks to mock out appSettings in my unit tests. Even if I was, the individual test projects should run under seperate app domains, so the problem would still exhibit if I ran one individual project. But like I said, the problem only occurs when I run all tests in the solution.

Any help would be appreciated.

2 comments
Comment actions Permalink

Hello Jorge,

  Regarding the second one: Please try ticking "ReSharper | Options | Tools | Unit Testing | Use separate AppDomain for each assembly with test" and check the issue again.

Thanks!

0
Comment actions Permalink

Hi Alexander,

Yep just worked that one out myself, thanks! And worked out I could run projects in parallel too since v6. Nice!

0

Please sign in to leave a comment.