AnjularJS support for R# 9.0

Hi,

How do I install AngularJS plugin for ReSharper 9.x. I tried to search in Extension Manager, but no luck.

Regards,
Hitesh

6 comments
Comment actions Permalink

I've just pushed a version that supports ReSharper 9 to the gallery. Try the Extension Manager again, and you should be able to install it.

0
Comment actions Permalink

Matt,

If that version is 1.2.0, then it is causing the Templates Explorer window to blank out.

I contacted support and got this response:

Angelina Elycheva (JetBrains ReSharper Support)
Dec 22 12:56
Hello Richard!
Thank you for the feedback.
AngularJS plugin doesn't support ReSharper 9 version yet - https://resharper-plugins.jetbrains.com/packages/AngularJS/
Thank you.

Any advice?

Richard

0
Comment actions Permalink

Hi Richard, yes it is supported, and the version is 1.2.0. I don't see the issue you're seeing. Can you confirm if you have any features disabled (ReSharper -> Options -> Products and Features). Can you also try running Visual Studio with the command line: "devenv.exe /ReSharper.Internal". This should enable exception reporting, so keep an eye out for a flashing red exclamation mark in the bottom right of the status bar. Try and show the templates explorer and see if any exceptions are thrown - that should hopefully let us know what's going wrong.

0
Comment actions Permalink

Oh, and the reason you're not seeing a ReSharper 9 version on that page is that's the package for ReSharper 8.x. ReSharper 9 requires new packages, unfortunately. Here's the one you get when you install in ReSharper 9 - https://resharper-plugins.jetbrains.com/packages/JetBrains.AngularJS/

0
Comment actions Permalink

Matt,

I removed all of the extensions and restarted VS 2013 Ultimate.  I started it with the /Resharper.Internal switch and no solution, and the Templates Explorer window shows as expected.  Then I installed the AngularJs 1.2.0 Extension, restarted VS it with the switch and the Templates explorer window is blank.  I see no exceptions being thrown.

What do you suggest I do next to detemine the cause of this?

Thanks

0
Comment actions Permalink

I don't really know, to be honest. Have you disabled any features in the Products & Features options page?

One thing you can try is to enable logging. With the /ReSharper.Internal switch enabled, go to the options dialog and down at the bottom, there's an option for logging. You can enable logging, and then click the edit button to open the config file. You'll need to edit this file to enable the file appender. Uncomment the "file" appender element near the top of the file, then make sure the "file" appender-ref element is uncommented about a page down. Restart VS, try and display the templates explorer, and then see what gets reported to the c:\logs\resharper-{date}.log file. Feel free to email this to me - matt.ellis at jetbrains.com.

0

Please sign in to leave a comment.