Can't start ReSharper9 on VS2010

Hi.
I can't start ReSharper9 on VS2010 Professional.

Activity log shows DLL loading error.

150 ERROR           C:\Users\xxx\AppData\Local\JetBrains\Installations\ReSharperPlatformVs10\JetBrains.Platform.VisualStudio.SinceVs12.dll
161 ERROR           C:\Users\XXX\AppData\Local\JetBrains\Installations\ReSharperPlatformVs10\JetBrains.PsiFeatures.VisualStudio.JustVs12.dll


So, I commented out the line including "JetBrains.Platform.VisualStudio.SinceVs12.dll" and "JetBrains.PsiFeathres.VisualStudio.JustVs12.dll"
on "extention.vsixmanifest" file at
C:\Users\xxx\AppData\Local\Microsoft/VisualStudio\10.0\Extensions\JetBrains\ResharperPlatformVs10\

But it's still has error.

234 ERROR CreateInstance failed for package  [JetBrains.ReSharperPlatformVs10.Product.VisualStudio.v10.0.Package,  Version=6.0.0.0, Culture=neutral, PublicKeyToken=1010a0d8d6380325] {0C6E6407-13FC-4878-869A-C8B4016C57FE} 80131604 VisualStudio 2014/12/05 07:05:11.771
235 ERROR End package load  [JetBrains.ReSharperPlatformVs10.Product.VisualStudio.v10.0.Package,  Version=6.0.0.0, Culture=neutral, PublicKeyToken=1010a0d8d6380325] {0C6E6407-13FC-4878-869A-C8B4016C57FE} 80004005 - E_FAIL VisualStudio


How can I start ReSharper9 on VS2010.

5 comments
Comment actions Permalink

Hello!

Thank you for contacting us.

Similar issue is reported to YouTrack - https://youtrack.jetbrains.com/issue/RSRP-428952
You are welcome to comment or vote for it.

Thank you.

0
Comment actions Permalink

To Angelina

Thank you for the reply.
The YouTrack you presented is the same problem.
I will wait for this problem to be fixed.

Thank you very much.

0
Comment actions Permalink

Hello,

Have there been any updates to the situation?

There in YouTrack I've had a guess of what might have happened to that VS10
(stale JB entries in the devenv.exe.config file). R# v<9 installer normally
adds them, but sometimes they won't get removed on uninstall, which would
totally prevent R# >9 from running.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Thanks for the reply.
I asked the support at "JetBrains ReSharper Support" page and this was solved.


There was a JetBrains ReSharper 8.2 entry under  
<configuration>
<runtime>
<assemblyBinding>
on devenv.exe.config file.


When I deleted all the "JetBrains ReSharper 8.2" entry and started VS2010, ReSharper 9.0 started.


Thank you very much for the support.

0
Comment actions Permalink

Hello,

Okay, good to know it worked.

I've returned here from the issue tracker request, it's still been open,
'dlike to close it now — though I don't know why R#8 uninstaller malfunctioned,
but at least the understanding of the situation is correct.
BTW newer VS versions won't have this problem because we were never writing
that devenv.exe.config for them.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.