Resharper 9.1.1 RC - unresolved binding path in XAML

I use ReSharper with Xamarin, and one of the best features under 9.1 is/was the XAML integration.

I upgraded to 9.1.1 RC because the blog recommended it for Visual Studio 2015 RC. Now, my Views can't see my ViewModels. All my Bindings report "Unresolved binding path when DataContext is unknown"

At the top, I have:

xmlns:mc=http://schemas.openxmlformats.org/markup-compatibility/2006
xmlns:d=http://schemas.microsoft.com/expression/blend/2008
mc:Ignorable="d"
d:DataContext="{d:DesignInstance viewModels:MyViewModel}"

Again, this was working this morning, before I upgraded ReSharper.

5 comments
Comment actions Permalink

Hello Jeremy,

  Are you able to attach a sample solution which will demonstrate the issue?

Thanks!

0
Comment actions Permalink

Attached as requested. You'll need Xamarin for Visual Studio installed. No license required.

You should see that MainText in the ExamplePage has an unknown datacontext with 9.1.1 RC, but it  resolves correctly on 9.1.



Attachment(s):
DatasourceExample.zip
0
Comment actions Permalink

Hi Jeremy,

Unfortunately, this is working fine on my PC.
Could you please try to clear caches in ReSHarper Options | General, reopen and rebuild the solution and check if it helps?

Thanks.



Attachment(s):
screen021.png
0
Comment actions Permalink

Tried clearing the cache, clean and rebuild. Even uninstall / reinstall of ReSharper. Still broken.

Uninstalled and reinstalled 9.1. Confirmed it still works correctly. This is definitely a ReSharper 9.1.1 problem.

From your screenshot I wonder if you misinterpreted the issue - the error shows if you mouse-over the {Binding MainText} on the Page, not the ViewModel. Take a screenshot of that to prove it to me :)

0
Comment actions Permalink

Hi Jeremy,

Thanks for clarifying! Indeed, I see the issue now. Logged this one as a regression bug here in YouTrack: https://youtrack.jetbrains.com/issue/RSRP-439748

Thank you for the report.

0

Please sign in to leave a comment.