Resharper 9.1 just as unreliable as 9.0, back to 8.x again...

Normally Resharper upgrades bring more good than bad, but you guys have fundamentally broken things so badly with 9.x. So many things no longer work reliably. We first had the issues with 9.0, uninstalled to go back to 8.2, waited for the latest 9.1, and its problems continue, so back to 8.2 yet again...

What sort of things? Well here are two of the absolute showstoppers for us...

  • Find usages (via ctrl+alt+F7) says no usages, but the code colouring (and reality) says otherwise. I can navigate from the line of code in another class using ctrl+click to that exact property, but Resharper still claims it isn't used

  • Intellisense type suggestions do not include all the results they should. So if I have a class called SpreadWatchGridViewModel, I expect to be able to do type SWGVM and somewhere along the way Resharper will start suggestiing the right class. Now in 9.x all it finds is sometimes an interface. If I start typing the full type name like SpreadWatchGrid and then do Ctrl+Space *then* Resharper gives me the suggestion correctly.

  • Similarly the finding of types using Ctrl+N is also proving unreliable in the same way as above.

    Is there an explanation? Are others seeing the same problems? Certainly multiple people here are all seeing the same problems.

    If I do a delete of the caches, allow Resharper to rebuild them again, then we get all the "correct" behaviour - for a while. But then after a period of time (such as the next day) when reloading the solution we are back to the same old behaviour of only partial or no suggestions.

    4 comments
    Comment actions Permalink

    Hello Grant

      Please install ReSharper 9.1.1 https://www.jetbrains.com/resharper/download/. If it still does not work properly, please attach a sample demo dolution which will demonstate the issues?

    Thanks!  

    0
    Comment actions Permalink

    Thanks Alex, will that new build a try then, hopefully there are some relevant fixes in there (is there a change list somewhere?). 8.2.3 just works flawlessly in regards to these issues above by comparison.

    0
    Comment actions Permalink

    We can report that Resharper 9.1.1 is just as broken as every other 9.x version. Once again reverting back to version 8. The "Find Usages" just *does not work* over a period of time, it "degrades" to the point of being dangerously useless.

    This is not just one developer experiencing the issue, all of our people are.

    0
    Comment actions Permalink

    Hello Grant,

      Sorry to hear that. My apologies for the inconvenience.

      Are you able to reproduce the issues in a sample solution?

    Thanks!

    0

    Please sign in to leave a comment.