Annoying Intellisense behavior in Resharper 9.1.1

I just upgraded from 9.0 to 9.1.1, and the behavior of when the Intellisense popup is shown has changed slightly, but in a very annoying way that makes me considerably less productive.

In version 9.0, I could type two characters as fast as I wanted and the Intellisense would popup immediately and let me autocomplete the rest of the word. For example, I could type "ov" followed by a space, as fast as possible, and Resharper would autocomplete that to "override".

But now, in version 9.1.1, there's a delay of maybe 1/4-1/3 of a second in which time if I stop typing or press space, the Intellisense won't show. Thus, if I type "ov" followed by a space, as fast as possible, Resharper won't autocomplete that and I'll be left with just "ov".

This is obviously super annoying.

Can you please fix this, or let me know what setting (if any) I need to change to make it work how it used to?

BTW, this is with Visual Studio 2013 Update 4.

Thanks!

2 comments
Comment actions Permalink

I have determined that this issue only happens as of 9.1.1. All the earlier versions I tested (9.0, 9.0.1, and 9.1) work as expected. I don't need any of the fixes in 9.1.1, so for now I've just rolled back to 9.1, but it'd be nice to have this fixed in future versions. Thanks! :)

(Also, thanks for making it so easy to install an old version over a new version.)

0
Comment actions Permalink

Hello Walter,

  Thanks for the report. Seems as if we found the root of the delay and we are going to fix it in ReSharper 9.2.

My apologies for the inconvenience.
Thanks!

0

Please sign in to leave a comment.