Clear Cache Needed Too Often

My team is finding that our Solution Analysis is getting corrupted often and we are forced to clear the cache (and restart VS).  Unfortunately some on the team have given up and simply ignore the solution wide analysis.  This can happen when switching from Debug to Release.  We've also seen it when switching between branches.  

Is there something that we can look into about our solution / setup that may help us?  A couple of things that may contribute: This is a solution of about 50 projects.  A number of the unit test projects are using Fakes - so we also have Fakes projects.  The source code takes up only about 15MB.

I'm sure this is somewhat isolated to us and this solution, because if it weren't there would be much wailing and gnashing of teeth in the Resharper community (and there doesn't seem to be).  Small demo solutions do not have the issue.

6 comments
Comment actions Permalink

it's 2021 and I'm having this same problem,  any solutions?

0
Comment actions Permalink

Travis Hawkins, sorry to hear you faced such difficulties. Could you please describe the problem in detail? Does it sound like the problem described in the original post? Thank you in advance for the reply!

0
Comment actions Permalink

Thanks for getting back to me.  The Solution is the same, I clear the cache 4-5 times a day to keep things running smoothly.

When OP says solution analysis is 'getting corrupted'. I could add some detail there.  In my case the keyboard starts reacting really slowly and sometimes the last word I typed will come out backwards or closer to backwards than forwards, it's just a jumble.

Also pasting anything while it's in this state ends up with like 1000 of the pasted item.  Clearly I didn't hit ctrl-v 1000 times, or hold it down for a long time. I just hit it once like normal and now I've got 1000 copies of it in my document.

I've never pushed it past that to see if any other aberrant behavior presents itself, I clear Resharper's cache and restart VS.

It seems like the more features of Resharper that I disable the less often this happens but my laptop is no slouch:

intel i9 -9th gen - 32bg ram, 1gb ssd with room to spare, 1GB ethernet connected directly.

Nothing else is slowing down and there's no reason for ReSharper to be.

Thanks!

 

0
Comment actions Permalink

Travis Hawkins, thanks for the reply! What ReSharper version are you using? Is it 2021.1.4 (ReSharper | Help | About JetBrains ReSharper)?

If so, could you please try disabling Inlay Hints in ReSharper | Options | Environment | Inlay Hints | General? Does it help? 

0
Comment actions Permalink

I am using version 2021.1.4 and I've turned off Inlay Hints and so far it's working well.  I'll give it a few hours and if it jams up again I'll get back to you.

Thanks so much for your help

0
Comment actions Permalink

Good! We're going to release 2021.1.5 with a fix for this problem shortly.

0

Please sign in to leave a comment.